Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Lexmark S600 cups-insecure-filter Help!

  1. #11
    Join Date
    Jul 2009

    Smile Lexmark S408 error "cups insecure filter"

    I have Lexmark S408 here. LinuxMint 17. Solved the error with:

    I just change the permission on the file :
    cd /usr/local/lexmark/v3/bin/
    sudo chmod 755 printfilter

  2. #12
    Join Date
    Mar 2015

    Thumbs up Re: Lexmark S600 cups-insecure-filter Help!

    solved here too I have a Lexmark Platinum Pro 905 (2 trays) connected to USB on Kubuntu 14.04

    this worked for me and here are steps I followed on a fesh and updated install of Kubuntu

    I downloaded these from Lexmark


    Right click on each >open with>QApt package installer>install package

    used the lexmark printer utility to add the printer

    opened printers from the hardware section of system settings

    I tried to print a test page and received the "cups-insecure-filter"

    then I followed sitro's post which only solved for me after adding the cups restart command

    cd /usr/local/lexmark/v3/bin/
    sudo chmod 755 printfilter
    sudo /etc/init.d/cups restart

    Print report

    all seems to work except for tray selection is in reverse, if I print to tray 2 it goes to tray 1 and if I print to tray 1 it goes to tray 2, I can live with that

    Scan report

    Found 4 devices each of which did not work for me at first, I would get a tearing image.

    Lexmark : Pro800-Pro900 Series

    Lexmark : Pro800-Pro900 Series

    Lexmark : Pro800-Pro900 Series

    Lexmark : Pro800-Pro900 Series

    I then installed xsane from muon discover and everything works perfect and about 20x faster even at 600dpi
    I went back to Skanlite for the sake of this post and it now works fine it is just slow hmm?

    Anyhow I hope this helps the head scratchers out there

    side note:
    I think my real problem that I had before I almost gave up trying to fix this printer problem after following all suggestions on these forums and elsewhere was I didn't follow proper procedure by using kdesudo and not sudo for gui applications namely dolphin which caused me problems and confusions regarding taking ownership of files. After seeing errors anytime I launched dolphin from Konsole I decided to do a fresh install.


Page 2 of 2 FirstFirst 12

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts