Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 43

Thread: University of Toronto Wireless

  1. #31
    Join Date
    Nov 2012
    Beans
    23

    Re: University of Toronto Wireless

    I still seem to be getting the same problem.

    I'll walk you through my steps to make sure I am doing it correctly.

    1. I typed nm-tool in the terminal and it returned a large list of connections. I looked through for all lines with ESSID equal to "UofT".
    2. I found the follow with a reasonable strength, assuming 100 is max strength as I didn't see anything higher than that:

    Code:
    UofT:            Infra, 00:0C:E6:48:B2:00, Freq 2437 MHz, Rate 54 Mb/s, Strength 87 WPA2 Enterprise
    3. I copied 00:0C:E6:48:B2:00 from above and entered it into my UofT connection in the network manager under BSSID. Additionally renamed it so I can organize as I assume I would have to make lots of these depending on location. (IPv6 is still set to ignore.)



    4. Tried connecting multiple times but still same results. Sometimes it works, other times it does not. Only chance for it to work is after a restart and trying again. (Worked in the morning but didn't report back as I wanted to test again. Now later in the day I'm back in the same building, just a few metres down in another room.

    So manually assigning the MAC address did not have any effect. :S

    Would this wicd you guys are talking about help?

    Thanks!

    Edit:

    First of all, please double-check the /etc/modprobe.d/ath9k.conf file. Make sure it says exactly:
    Code:
    options ath9k nohwcrypt=1
    Forgot to confirm, I have checked and indeed it is correct.
    Last edited by mabubakr94; November 22nd, 2012 at 07:59 PM.

  2. #32
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: University of Toronto Wireless

    Quote Originally Posted by mabubakr94 View Post
    Would this wicd you guys are talking about help?
    Not sure if Dr. chili would approve of it yet, but I'd say let's give it a shot. However, using two network managers simultaneously would almost certainly cause problems, and I won't advice to uninstall network manager unless wicd proves its worth.

    So we'd only disable nm while we use wicd for a test. To install wicd -
    Code:
    sudo apt-get install wicd
    After it is downloaded and installed, we need to prevent Network Manager from loading at startup. To make it visible in "Startup Applications" dialogue box we have to edit its .desktop file in /etc/xdg/autostart/ directory -
    Code:
    gksu gedit /etc/xdg/autostart/nm-applet.desktop
    Look for the line that says - "NoDisplay=true".
    Change the value to "false", so the file looks like -
    Code:
    [Desktop Entry]
    Name=Network
    Comment=Manage your network connections
    Icon=nm-device-wireless
    Exec=nm-applet
    Terminal=false
    Type=Application
    NoDisplay=false
    NotShowIn=KDE;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=NetworkManager
    X-GNOME-Bugzilla-Component=general
    X-GNOME-Autostart-enabled=true
    X-Ubuntu-Gettext-Domain=nm-applet
    Save and close gedit. DO NOT touch any other line unless you know what you are doing. (* it is always a good practice to create a backup of system files before messing with them)

    Now open Startup Applications dialogue (Power button > Startup Applications...). You should see the NM-applet icon here with name -"Network". Just clear the check-box before it to disable it from loading at startup (you can still load it manually by pressing Alt+F2 > type nm-applet > press 'Enter'. To permanently re-enable it, if needed later, we'd only need to put a tick in the check-box again.)

    Now reboot, run wicd, save the required settings, try to connect and see how well it performs.
    I'm not sure, but AFAIK, it needs to be started manually, and won't give you any system-tray indicator like nm-applet. If that's true (I'd appreciate your feedback on its functioning), all you'd need to do is load (manually) nm-applet instead of wicd if you find it unsatisfactory. Of-course you can also delete it and all its settings, configuration files with -
    Code:
    sudo apt-get purge wicd
    PS :
    Here's something extra, although unrelated -
    If you browse to /etc/xdg/autostart directory, you'd see many files like nm-applet.desktop. All of them are startup applications which don't appear in the Startup Applications dialogue-box by default. You can make them visible using the same steps as we did with nm-applet.desktop above.

    My favourite one-liner method to make all of them visible in one step is -
    sudo sed -i 's:NoDisplay=true:NoDisplay=false:' /etc/xdg/autostart/*.*
    [if you don't already know, we can always use colon (: ) or underscore ( _ ) instead of slash ( / ) as separators in sed, whatever looks better.]
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #33
    Join Date
    Nov 2012
    Beans
    23

    Re: University of Toronto Wireless

    Hmm. I'm on Ubuntu 12.10 so I could not find the startup applications window by clicking the power button. I used Alt + F2 and typed in:

    Code:
    gnome-sessions-properties
    It did seem to work as I was able to disable the network manager from starting up.

    However, wicd did not seem to have any positive effect. It says 'awaiting authentication' for a while but then it also seems to time out. Basically, the same result as network manager.

    I was surprised this morning when the connection started working when I specified the address but once again it was random as now I am not able to connect. I think I will keep trying with network manager unless you have any other solutions.

    It sucks how the school IT does not offer support for Linux.

  4. #34
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: University of Toronto Wireless

    Quote Originally Posted by mabubakr94 View Post
    Hmm. I'm on Ubuntu 12.10 so I could not find the startup applications window by clicking the power button.
    Just booted a 12.10 32bit iso in a VM and found that missing. However, you can still access it by typing "Startup" in Dash.

    Another easier way is to just copy the nm-applet.desktop file into .config/autostart directory (create if doesn't already exist) in your Home, then toggle the value of line "X-GNOME-Autostart-enabled=" to "true" or "false" to enable/disable nm at startup.

    Anyway, I remembered something from 3 years back when I was an IT executive in a college and dealt with similar problems in students' laptops. A quick search returned these -
    https://en.wikipedia.org/wiki/Wirele...nt#Limitations a snippet -
    One IEEE 802.11 AP can typically communicate with 30 client systems located within a radius of 103 m
    and -
    http://compnetworking.about.com/od/w...anydevices.htm
    Connecting 255 computers to a single WiFi access point, while theoretically possible, is not recommended
    Now since you seem to be dual booting with windows, can you verify if you can connect to the same access-point (MAC or BSSID) in windows when it fails to connect in Ubuntu?
    Obviously, I'm thinking of a possibility if the number of allowd connections or dhcp pool of an access-point gets saturated, and we are still trying to connect to it.

    If this assumption has any substance and the "nm confusion with multiple APs of same name" is the only problem left, then maybe creating multiple profiles with same SSID but different BSSIDs may help by switching to other if one fails.
    Although looking at the profile-name in your screenshot, I suspect if you have already tried that.

    Regardless, please confirm the scenario with Windows if there's a way (or if you can find a way) to connect to specifically the same access-point which fails to connect in Ubuntu - obviously, immediately after it fails (and try back in ubuntu if it does successfuly connect in windows).

    As for wicd, since it didn't help, I think you should purge it to avoid any possible conflicts -
    Code:
    sudo apt-get purge wicd
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #35
    Join Date
    Nov 2012
    Beans
    23

    Re: University of Toronto Wireless

    I completely wiped my windows partition but I am always connecting with my Android phone to make sure it is not the access point which has a problem. It always works on my phone.

    If I understand correctly, multiple signals can cause the connections to get weird. As sometimes I have noticed that in some of my classes, being first year they are quite big (~1500 students in my largest), the connections fail when everyone boots up their laptop. However when I wait until we're midway through the lecture and less people are repeatedly trying to connect, I see more success.

    As for the issue of a limited number of users allowed on a single access point, I'm not sure if that could be causing the problem. In one of my lecture halls I counted at least 6 routers in a class with around 250 students.

    I will try once again with your suggestion of making multiple profiles with same SSID. Currently I only had one made for each lecture hall, I simply configured it each time by doing 'nm-tool' and changing SSID to the strongest one.

    I'll let you know how it goes.

    Thanks!

  6. #36
    Join Date
    Nov 2012
    Beans
    23

    Re: University of Toronto Wireless

    OK. It seems to be working fairly well now. Sometimes it is on and off but no worse than when on Windows 7.

    Thanks for your help!

  7. #37
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,149
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: University of Toronto Wireless

    Quote Originally Posted by mabubakr94 View Post
    OK. It seems to be working fairly well now. Sometimes it is on and off but no worse than when on Windows 7.

    Thanks for your help!
    Glad at you find it at least usable now, and sorry for leaving it in a confused state and not being able to help you more on this. But I guess that was all I could think of with my current knowledge and experience.

    I very much appriciate your persistence and willingness to work through it all. I actually learned quite some new things from this thread which I'm sure would help me strengthen my skills and be more precise next time I deal with similar problems. I really owe a big thanks to you for your clear and comprehensive feedbacks and positive attitude all this while - "THANK YOU"!

    I think you should mark the thread as [Solved] now IF you really find the connectivity and stability good enough to be called 'satisfactory', but leave it open if it still is an 'annoying' game of hit and miss, so we know we still need a lot of improvement to reach that level.

    In any case, we all would certainly appreciate your report on what all changes you have applied and maybe a description of how it is performing now.

    Thanks!

    Varun
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  8. #38
    Join Date
    Nov 2012
    Beans
    23

    Re: University of Toronto Wireless

    Hi.

    I was trying to set it to solve but was unable to locate the option when I was in class. I found it now and have done so.

    These are the final settings which seem to have made the wireless usable.

    Code:
    nohwcrypt = 1
    power management = on (Figured turning it off had no difference.)
    Using Network manager, wicd performed no better, maybe even worse.
    IPv6 was initially disabled but even with it on, experienced same results. Left it on for now.
    Chili's suggestion to manually specify MAC seemed to do the trick. Initially it showed no improvement but once again there were a lot of access points to choose between. I simply tried cycling between them and eventually it works. It is not ideal but I manually set the address each time I want to connect. However, it is not too bad as I am a CS student so I am mostly in the CS buildings which have the other connections that easily connect to Ubuntu.

    Only one lecture hall does not seem to work but that had problems even on Windows 7, my guess is because of the number of people connecting in that hall. (~1500 - 2000 people)

    Once again, thanks a lot for your help. Really starting to enjoy using the terminal or cmd prompt.

    Still have some issues to fix such as not completely powering off on shutdown and card reader not working, but that will have to wait until after exams.

  9. #39
    Join Date
    Dec 2011
    Beans
    3

    Re: University of Toronto Wireless

    It looks like you've got it working, but I thought I'd put this on here anyway.

    I'm at the UTSC campus, but I imagine the login's the same across the board. I got it working with the same setup you described above, (WPA & WPA2 Enterprise; PEAP; PEAP Ver. Automatic; MSCHAPv2)

    Except for the Certificate. Use: /usr/share/ca-certificates/mozilla/AddTrust_External_Root.crt

    Hopefully this helps.

  10. #40
    Join Date
    Nov 2012
    Beans
    23

    Re: University of Toronto Wireless

    Quote Originally Posted by dapper.ic View Post
    It looks like you've got it working, but I thought I'd put this on here anyway.

    I'm at the UTSC campus, but I imagine the login's the same across the board. I got it working with the same setup you described above, (WPA & WPA2 Enterprise; PEAP; PEAP Ver. Automatic; MSCHAPv2)

    Except for the Certificate. Use: /usr/share/ca-certificates/mozilla/AddTrust_External_Root.crt

    Hopefully this helps.
    I got it working most of the time but even then it takes multiple tries. I'll try out this certificate tomorrow. Thanks!

Page 4 of 5 FirstFirst ... 2345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •