Sometimes I'm seeing version names like the current nvidia-current version: 304.51.really.304.43-0ubuntu2

Why is this version called with this name? If this package is really the version 304.43 why isn't it just called 304.43-0ubuntu2?