Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: super/win key not working for global keyboard shortcuts

  1. #1
    Join Date
    Aug 2008
    Beans
    46
    Distro
    Ubuntu 12.04 Precise Pangolin

    Unhappy super/win key not working for global keyboard shortcuts

    I want to configure some global shortcut key, for music players & others, with combination of win/super key. I have a standard Windows keyboard (US layout) with 104 keys. here is an image of my keyboard.

    Navigating to System > Preferences > Keyboard Shortcuts, I tried to change the shortcut for play/pause. I changed the shortcut to Mod4+X. But the shortcut does not seems to be working. I tried changing to some different shortcut like Ctrl+Alt+X. And it works. It play/pauses my media player. But changing to any shortcut with combination of super/win key does not work.

    My keyboard layout is set to Generic 105-key (Intl) PC with default settings. I am using Ubuntu 8.04 Hardy.

    Am I doing something stupid ????

  2. #2
    Join Date
    Jun 2006
    Location
    UK
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: super/win key not working for global keyboard shortcuts

    I'm curious. How did you get the Mod4 code into the shortcut field? In Keyboard Shortcuts, if I highlight one of the functions, I get 'New Accelerator..' appearing in that field, and then when I press the Windows key alone, the code 'Super L' appears, and using the Windows key activates that function.

    By experimenting, I found I could combine the Windows key with shift and alt, but with any of the character keys, only 'Super L' got written to the shortcut field or I got a message telling me I couldn't use a character key as a shortcut.

    One oddity I found while investigating this. When I pressed Windows Key + 3, the screen zoomed in. Super+2 does a lesser zoom and Super+1 zooms out to the ordinary desktop again. Which is strange because in Keyboard Shortcuts, both Zoom in and Zoom out are said to be disabled.

  3. #3
    Join Date
    Feb 2007
    Beans
    4,045
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: super/win key not working for global keyboard shortcuts

    In System -> Preferences -> Keyboard. Under the Layout-tab, choose your layout and hit the "Layout Options" button. In there, try changing the values under Alt/Win key behavior. I have "Super is mapped to the Win-keys" there, and I've mapped Win+t to open a terminal.

  4. #4
    Join Date
    Aug 2008
    Beans
    46
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: super/win key not working for global keyboard shortcuts

    Quote Originally Posted by coffeecat View Post
    I'm curious. How did you get the Mod4 code into the shortcut field? In Keyboard Shortcuts, if I highlight one of the functions, I get 'New Accelerator..' appearing in that field, and then when I press the Windows key alone, the code 'Super L' appears, and using the Windows key activates that function.
    yeah you are right... I also got 'Super L'. But after few trial I found how to get Mod4+<anything>. here are the steps

    1. click once on any function to get 'New Accelerator'
    2. press win key. you will get 'Super L' (L denotes left win key)
    3. click on the function again holding, the win key(i.e. keep win key pressed once you press it the 1st time)
    4. now you have win key pressed & 'New Accelerator' in the shortcut. Now just press any new character. you should get Mod4+ <character>

  5. #5
    Join Date
    Aug 2008
    Beans
    46
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: super/win key not working for global keyboard shortcuts

    Quote Originally Posted by geirha View Post
    In System -> Preferences -> Keyboard. Under the Layout-tab, choose your layout and hit the "Layout Options" button. In there, try changing the values under Alt/Win key behavior. I have "Super is mapped to the Win-keys" there, and I've mapped Win+t to open a terminal.
    I had already tried that without any success. But after your post I tried again, but this time I modified the shortcut for new terminal. And it worked.

    But the interesting part is that the similar shortcut (win+X) when configured for the music player does not work. I configured the shortcut for play/pause. I tried with another shortcut (Ctrl+Alt+X).. & it worked

    It seems that my music player (rhythmbox) is not happy with win key. I tried with a few different functions. I found that 'Home Folder' option also do not work with shortcuts with win key.

    I am highly confused.

  6. #6
    Join Date
    Oct 2006
    Beans
    459

    Re: super/win key not working for global keyboard shortcuts

    You aren't the only one. I figured this out once, but now cannot get the Super key to work by itself. If I press "Z" it will come up Mod4+Z but still doesn't work.
    It shouldn't be this hard.
    Standard 104 keyboard with Wake, Sleep, and Power.
    Hardy 64 bit on the hardware listed in sig.
    Google is your friend...Ubuntu 9.10 Karmic Koala 64 bit Foxconn WinFast 761GXK8MC-S AMD 64 3200+ 1 GB DDR2, nVidia 8500GT
    Production platform - Intrepid 64 bit 8.10 ASRock ALiveNF6P Phenom 9600 2GB DDR2 GeForce6x and Beryl/Compiz/Desktop Effects

  7. #7
    Join Date
    Jan 2009
    Beans
    2

    Re: super/win key not working for global keyboard shortcuts

    hi all. i tried the "Super is mapped to the Win-keys" option under keyboard settings and after removing conflicts with the compiz effects, was able to configure the Win key with other modifier keys to control rhythmbox (play/pause, next, etc.), start a terminal and control gnome volume, without any hitches. thanks to all for the advice.

    btw, i'm using ubuntu 8.10, probably the bug (if any) was removed in this release.

  8. #8
    Join Date
    Aug 2008
    Beans
    46
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: super/win key not working for global keyboard shortcuts

    I checked again with "meta mapped to win-keys" on Ubuntu 8.10 and it works.
    thanks to all for the advice.

  9. #9
    Join Date
    Feb 2007
    Location
    Slovenia
    Beans
    251
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Unhappy Re: super/win key not working for global keyboard shortcuts

    Using Ubuntu 8.10. The Win/Super key stopped working for some reason. And when I reinstalled Ubuntu (8.10) it still doesn't work.

    It's not even detected by xev

  10. #10
    Join Date
    Jul 2007
    Location
    Iasi, Romania
    Beans
    8
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: super/win key not working for global keyboard shortcuts

    Quote Originally Posted by geirha View Post
    In System -> Preferences -> Keyboard. Under the Layout-tab, choose your layout and hit the "Layout Options" button. In there, try changing the values under Alt/Win key behavior. I have "Super is mapped to the Win-keys" there, and I've mapped Win+t to open a terminal.
    This worked for me, I have a Dell Inspiron 1501 laptop and Ubuntu Jaunty. Thanks!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •