I had to install Windows 7 on my System76 Serp7 over the summer (using these instructions: http://knowledge76.com/index.php/Win...stem76_Machine ) so as to run RobotC, which I need desperately for my Robotics team. All was going well (aside from a number of Windows-induced crashes, necessitating the reinstallation of Windows on several occasions) until I tried to enlarge my Windows partition. I did this by referring back to the previously mentioned instructions (simply because I knew that those instructions worked once), and the shrinking of my Ubuntu partition worked fairly well. However, when I tried moving the 100Mb "System Reserved" partition to the left I got an error message claiming that the filesystem was corrupt. I then accidentally deleted the System Reserved partition, and am now receiving the same error message upon trying to move the main partition (on SDA 3). The error message states that one node on the NTFS is being referenced 3 times, making it unreadable. However, I tried using an AVG live disk to solve the problem, and the AVG disk was able to read the files in the filesystem very accurately. I would like to know how I can recover my Windows installation, since I had several critical files on it.

I apologize if I have failed to explain my problem in a satisfactory manner, and hope that you will be able to offer assistance.