First, here's some background:

Ubuntu 12.04 64bit, graphics card: Advanced Micro Devices [AMD] nee ATI Whistler [AMD Radeon HD 6600M Series] (output from lspci | grep VGA)

My whole issue stemmed from trying to give different workspaces different backgrounds. To this end, I installed compizconfig-settings-manager.

Then I did something stupid, not knowing precisely what compiz or unity is: I first ran the command 'compiz', which gave me some kind of message saying 'try compiz --replace instead.' So I ran 'compiz --replace,' and that's when the problems started.

Basically, everything works fine, except that my task switcher (alt-tab) is an ugly gray color that shows only the icons and not miniature versions of windows. Also, when I log in, I get a grey screen for a moment, which later goes away. My workspace switcher (ctrl-alt-arrow) is also ugly and gray. I suppose the issues a merely cosmetic, but I cannot figure out how to get the 'pretty' versions back.

I been to a huge amount of threads, blogs, and pages related to this, and nothing I've done seems to resolve the issue. I've tried unity --reset (seg fault), ccsm (doesn't have any effect).

One thing that seems likely to me is that I am somehow stuck in Unity-2d. I have no idea how to get to 3d. The graphics driver I'm using (amd / ati fglrx) seems to be installed and activated.

Does anyone know
1. what is it about compiz --replace that can make everything ugly
2. if I can simply revert my system setting to 24 hrs ago, before the problem started?

Please let me know of any other kinds of information I need to provide.

Thank you.