Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: How to disable automatic shutdown - Critical temperature reached (97 C)

  1. #1
    Join Date
    Feb 2011
    Beans
    9

    [Solved] - How to disable automatic shutdown - Critical temperature reached (97 C)

    Hi there,

    I have a Dell Inspiron 15R laptop with a i7 processor and 8GB of RAM. I am running Ubuntu 10.10 and I have seen various trouble shooting guides for acpi, however I cant find clear information on how to disable the automatic shutdown when the critical temperature has been reached or how to increase it.

    I am trying to convert a movie with Handbrake and it utilises processing power that takes the temperature up to the maximum acpi value of 97 degrees then the system shuts down without warning.

    This is HIGHLY annoying and it caused me to lose work. I would at least expect a warning and some kind of human intervention option to prevent this from happening.

    Any help/suggestions?

    Thanks
    Last edited by restofactor; March 24th, 2011 at 09:48 AM. Reason: Noting that the issue is solved.

  2. #2
    Join Date
    Oct 2008
    Location
    Cambrils (Tarragona)
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    I don't think there's a way to disable this.. it's the bios taking care. Maybe you could get the acpi dsdt, decompile it, disable that, then recompile the dsdt and, last thing, compile a custom kernel with the dsdt in it.. but, honestly, I don't think anyone would like to do that.

    Something is wrong with your computer. No matter what you do, it shouldn't reach critical temparutes as yours. If it does, I think there are basically four options:
    1.- because the software (os, drivers) is not managing the fans as it should
    2.- because the laptop's cooling system is poorly designed and can't cool that processor
    3.- because you upgraded the processor to something too hot.. which the cooling system wasn't designed to take care of
    4.- because it's broken (bad fan, fan temperature sensors, etc)

    Since your machine is quite new, I'd say yours is case 1. Disabling the acpi stuff isn't a good idea: what will happen if, after disabling it, you leave and forget about it?
    Busques ajuda? Comença pel wiki de l'equip català!

  3. #3
    Join Date
    Jul 2008
    Beans
    2,825

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    Never disable automatic shut down. It shutting down because your running too hot. Best to repair your problem than burn out your computer. GL

  4. #4
    Join Date
    Feb 2011
    Beans
    9

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    I appreciate the feedback, however you guys are not answering my question. If I go back to my original question I asked how do I disable this feature.

    After a lot of reading I did this and then I rebooted. I ran the temperature up again and it shut down so I am not sure whether this is working;

    Code:
    Edit => /etc/default/grub
    
    Edit => GRUB_CMDLINE_LINUX_DEFAULT=
    
    Add => GRUB_CMDLINE_LINUX_DEFAULT="quiet splash thermal.nocrt=1"
    
    Update GRUB => sudo update-grub
    
    View settings, should be disabled => cat /proc/acpi/thermal_zone/THM/trip_points
    
    View temperature => acpi -V or sensors
    I then found and did as per the following write up on the issue and it seem to have worked => http://burnz.wordpress.com/2009/02/2...u-temperature/
    Last edited by restofactor; March 20th, 2011 at 07:17 AM.

  5. #5
    Join Date
    Mar 2007
    Beans
    70
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    I appreciate the feedback, however you guys are not answering my question. If I go back to my original question I asked how do I disable this feature.
    I think that what people are saying is that you have another much more serious problem with your computer that you are ignoring. My laptop [Dell Inspiron 1501] NEVER gets hotter than 62 degrees. If yours is doing this then (i) check the fans - are they working? are they clogged with cat hair and dust? (ii) get an external laptop cooler - the fan thingy that goes under your laptop to cool it more.
    Run Powertop (and maybe htop) and see if there is some process that is using 100% CPU all the time, or doing something to raise the temperature.
    If you can't find a solution to these high temperatures, then take it in to get a technician to look at it.
    Disabling the autoshutdown feature is just plain dumb -- you might as well just stick the laptop in an oven. Of course, if you are living in the desert, than maybe there is another reason why it is getting so hot. I don't think laptops would work in desert heat.

  6. #6
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,434
    Distro
    Ubuntu Development Release

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    Quote Originally Posted by restofactor View Post
    I appreciate the feedback, however you guys are not answering my question. If I go back to my original question I asked how do I disable this feature.
    On the contrary, you aren't reading the answers.

    Lets clarify a few things. Most people consider 70C hot for a CPU. Getting to 97C is likely above the maximum recommended operating temperature. The machine is shutting itself down to protect the CPU from melting/burning. This would be far more annoying/expensive than just having the computer shut down.

    So in conclusion, it's the BIOS, not Ubuntu that is shutting the system down. You may be able to disable the safety measures in the BIOS, but no, I won't help you ruin your computer.
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  7. #7
    Join Date
    Jul 2008
    Beans
    2,825

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    To give an answer that may kill your computer is just NOT right. Read the post and get your fan running is the answer. GL

  8. #8
    Join Date
    Feb 2011
    Beans
    9

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    Quote Originally Posted by tgm4883 View Post
    On the contrary, you aren't reading the answers.

    Lets clarify a few things. Most people consider 70C hot for a CPU. Getting to 97C is likely above the maximum recommended operating temperature. The machine is shutting itself down to protect the CPU from melting/burning. This would be far more annoying/expensive than just having the computer shut down.

    So in conclusion, it's the BIOS, not Ubuntu that is shutting the system down. You may be able to disable the safety measures in the BIOS, but no, I won't help you ruin your computer.
    Dude, Cheryl Cole is hot, anything else is pale in contrast!

    What annoyed the fQ@#%$@# out of me was watching my laptop shut down 10mins every time into an AcidRIP session without any warning - causing me to lose all my work open at the time. I'd much rather lose a processor than go through this kind of pain again. It is only when I use AcidRIP that the temp goes up.

    This is my current temp;

    Code:
    acpitz-virtual-0
    Adapter: Virtual device
    temp1:       +66.5°C  (crit = +97.0°C)
    On my laptop it is not controlled via the BIOS, as noted in my previous post the changes in Ubuntu fixed the automatic shut down.

  9. #9
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,434
    Distro
    Ubuntu Development Release

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    Quote Originally Posted by restofactor View Post
    Dude, Cheryl Cole is hot, anything else is pale in contrast!

    What annoyed the fQ@#%$@# out of me was watching my laptop shut down 10mins every time into an AcidRIP session without any warning - causing me to lose all my work open at the time. I'd much rather lose a processor than go through this kind of pain again. It is only when I use AcidRIP that the temp goes up.

    This is my current temp;

    Code:
    acpitz-virtual-0
    Adapter: Virtual device
    temp1:       +66.5°C  (crit = +97.0°C)
    On my laptop it is not controlled via the BIOS, as noted in my previous post the changes in Ubuntu fixed the automatic shut down.
    If you lose your processor, you lose your unsaved work (and potentially your saved work too). It doesn't magically save stuff just because you disable the safety measures.

    Again, I'm not going to help you disable safetly measures, sorry. Laptops don't generally get that hot doing normal activity, heck even when encoding they don't get that hot. I'd check your airflow.
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  10. #10
    Join Date
    Feb 2011
    Beans
    9

    Re: How to disable automatic shutdown - Critical temperature reached (97 C)

    Quote Originally Posted by tgm4883 View Post
    If you lose your processor, you lose your unsaved work (and potentially your saved work too). It doesn't magically save stuff just because you disable the safety measures.

    Again, I'm not going to help you disable safetly measures, sorry. Laptops don't generally get that hot doing normal activity, heck even when encoding they don't get that hot. I'd check your airflow.
    It is okay, I successfully disabled it and posted my solution for everyone else annoyed by this.

    It is fine to warn people, but give people the freedom to do what they want.

    My laptop is under warranty, if it gets fried I will take it in and get a new one I ran it for more than an hour at 97 without any issues. Still strong as mother Russia!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •