Results 1 to 4 of 4

Thread: Enebling microphone-connector on eeePC 1001PX

  1. #1
    Join Date
    Nov 2012

    Enabling microphone-connector on eeePC 1001PX

    Hi there,

    this is my first post in this forum and I directly have a question concerning the audio-settings on my Asus eeePC 1001PX, which has a combined headphones out/mic in connector.
    What I'm trying to do is using the connector for some quick recordings out of a small mixing desk (I'm absolutely aware of the fact that I cannot expect high quality recordings with that A/D-converter, we only need these recordings in a band for self evaluation).

    I now have the problem that I do not know how to access this dual connector as a capture device?

    Here's some more background:
    I spoke with the Asus support, they said that its some kind of "ether/or" connector, so it's not the case that I just have to use a 4-pole jack.
    They also said that the driver should somehow recognize whether the connector has to be addressed as a line in or line out. Unfortunately they do not support Linux systems.

    I'm using Lubuntu 12.04 32bit with the universe lowlatency-Kernel, using jack for some audio applications, apart from that ALSA. Pulseaudio is not installed, nor is esd or arts.
    I tried playing with the settings in alsamixer, I tried the different capture-devices in qjackctl but every listed device only contains the signal out of the integrated microphones.
    I've tried both modes laptop-amic and laptop-dmic mentioned in /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt without success.

    Here is some more information about the system:
    $ cat /proc/asound/cards
    0 [Intel          ]: HDA-Intel - HDA Intel
                           HDA Intel at 0xf7cf8000 irq 45
    $ head -n 1 /proc/asound/card0/codec* 
    Codec: Realtek ALC269
    $ lspci -nnk | grep -iA2 audio
    00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8442]
        Kernel driver in use: snd_hda_intel
    $ lsmod | grep "snd"c* 
    snd_hda_codec_realtek   174313  1 
    snd_hda_intel          32765  1 
    snd_hda_codec         109562  2 snd_hda_codec_realtek,snd_hda_intel
    snd_hwdep              13276  1 snd_hda_codec
    snd_pcm                80845  2 snd_hda_intel,snd_hda_codec
    snd_seq_midi           13132  0 
    snd_rawmidi            25424  1 snd_seq_midi
    snd_seq_midi_event     14475  1 snd_seq_midi
    snd_seq                51567  2 snd_seq_midi,snd_seq_midi_event
    snd_timer              28931  2 snd_pcm,snd_seq
    snd_seq_device         14172  3 snd_seq_midi,snd_rawmidi,snd_seq
    snd                    62064  11 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    soundcore              14635  1 snd
    snd_page_alloc         14115  2 snd_hda_intel,snd_pcm
    And the AlsaInfo:

    I'm sorry for my bad English, I'm from Germany

    Thanks a lot for your help in advance,
    Last edited by resruta; November 4th, 2012 at 03:07 PM. Reason: AlsaInfo added

  2. #2
    Join Date
    Jun 2007

    Re: Enabling microphone-connector on eeePC 1001PX

  3. #3
    Join Date
    Nov 2012

    Re: Enebling microphone-connector on eeePC 1001PX

    Thank you so much for that hint.
    This tool is awsome and instantly solved my problem.

    Thank you !

  4. #4
    Join Date
    Jun 2007

    Re: Enebling microphone-connector on eeePC 1001PX

    You're welcome. Enjoy!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts