Results 1 to 4 of 4

Thread: Ubuntu 12.04 Chrome Java Plugin

  1. #1
    Join Date
    Nov 2012
    Beans
    1

    Ubuntu 12.04 Chrome Java Plugin

    Google Chrome does not detect java. I know this topic has been post everywhere, but I try their suggestions and it does not work. I need your help to know if there is anything I am doing wrong or anything I have not done yet.
    This is what I have and what I have done
    Ubuntu 12.04 recently installed
    Java(TM) SE Runtime Environment (build 1.7.0_09-b05)
    Google chrome Version 22.0.1229.94.
    I also have firefox 16.0.2, and JAVA works fine there (using IcedTea pluging)

    What I have done,
    I installed Java from the terminal
    Then Icedtea plugin, also from the terminal, at this point java started working on firefox, which makes me think Java is working fine
    I searched for the java lib using the command (find / -name libjava.so 2> /dev/null)
    once it founded the lib I created a link of the "libnpjp2.so" to the chrome plugins folder using the following command "sudo ln -s /usr/lib/jvm/java-7-oracle/jre/lib/i386/libnpjp2.so /opt/google/chrome/plugins/"
    It did the link in the folder, but still when I go to Java to test, using the chrome browser, java does not work.

    Any suggestions?

    Thanks a lot

  2. #2
    Join Date
    Jan 2012
    Beans
    81

    Re: Ubuntu 12.04 Chrome Java Plugin

    Install default-jdk using Synaptic

    works for me. ymmv

  3. #3
    Join Date
    Sep 2010
    Location
    Central Calif
    Beans
    1,208
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Ubuntu 12.04 Chrome Java Plugin

    In chrome 'Current Settings', are all sites allowed to run JavaScript?

    Did you install openjdk-7-jre? It should be in Software Center.
    Last edited by critin; November 3rd, 2012 at 06:15 PM.
    Remember When Double-Dog dare ya's and water balloons were the ultimate weapon?

  4. #4
    Join Date
    Feb 2010
    Beans
    2

    Smile Re: Ubuntu 12.04 Chrome Java Plugin

    The best solution I found, (none of these suggestions worked for me), is as followings:
    First install Icedtead pluging by:

    • 1) sudo apt-get install icedtea-7-plugin


    Then in your chrome browser go to:

    • 2) chrome-> Settings-> Show Advanced Settings-> Privacy then click on
    • Content Settings -> Plug-ins then click on Disable Individual Plug-in
    • 3) Disable both "IceTea-Web Plugin" and "Java(TM)"
    • 4) Restart the browser.
    • 5) chrome-> Settings-> Show Advanced Settings-> Privacy then click on
    • Content Settings -> Plug-ins then click on Disable Individual Plug-in
    • 6) Enable only "IceTea-Web Plugin"
    • 7) Enjoy !

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •