Results 1 to 3 of 3

Thread: Cloned USB stick won't boot

  1. #1
    Join Date
    Aug 2012

    Cloned USB stick won't boot

    I made a bootable USB stick, it has /boot, /, and swap partitions. It was becoming unreliable so I cloned it with gparted, and set the 'boot' flag on the boot partition. The new one won't boot. I think it's because I have yet to install grub, so there's no grub in the MBR. Assuming I know the device name of the stick (e.g. /dev/sde) what grub-install command would I use to get this clone working? Thanks.

  2. #2
    Join Date
    Nov 2009
    Mataro, Spain
    Ubuntu 14.04 Trusty Tahr

    Re: Cloned USB stick won't boot

    You will have to use the cd of the same version in live mode, or live usb, and know the exact number of the /boot and / partitions.

    Since you have /boot partition too, you have to mount both before running the grub-install. The commands for a usb stick called /dev/sde would be:
    sudo mount /dev/sdeX /mnt (the / partition)
    sudo mount /dev/sdeY /mnt/boot (the /boot partition)
    sudo grub-install --root-directory=/mnt /dev/sde
    That will install it on the MBR of /dev/sde.
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  3. #3
    Join Date
    Aug 2012

    Re: Cloned USB stick won't boot

    Worked perfectly (in the end!). Tried it from the original USB stick, got a "bus error". Dug out the original install CD and booted from that, second time lucky. Thank you!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts