Results 1 to 2 of 2

Thread: Samba and passwords with special characters

  1. #1
    Join Date
    Apr 2005
    Location
    Redwood City, CA, USA
    Beans
    178
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Question Samba and passwords with special characters

    Hi all,

    I have created a server at work, connected to the domain via Centrify.

    My Windows domain password has an exclamation mark at the end (!). When I try to access a share, I am prompted to enter my password; it never works (I keep getting prompted). Once I change my password to not have special characters, it works.

    Is there something I need to put in my smb.conf to work with special characters? I tried with Ubuntu and openSUSE so it seems to be a Samba specific issue. I have sent an email to the Samba mailing list. My smb.conf is listed below:

    Code:
    #
    # This file was generated by Centrify ADBindProxy Utility
    #
    [global]
        security = ADS
        realm = ***.**.**.***
        workgroup = ****
        netbios name = shockwave
    
        auth methods = guest, sam, winbind, ntdomain
        machine password timeout = 0
        passdb backend = tdbsam:/etc/samba/private/passdb.tdb
    
        #
        # Samba versions 3.4.0 and newer have replaced "use kerberos keytab"
        # with "kerberos method".  The directive "kerberos method = system keytab"
        # enables Samba to honor service tickets that are still valid but were
        # created before the Samba server's password was changed.
        #
        kerberos method = system keytab
    
    
        #
        # Setting "client use spnego principal" to true instructs SMB client to
        # trust the service principal name returned by the SMB server. Otherwise,
        # client cannot be authenticated via Kerberos by the server in a different
        # domain even though the two domains are mutually trusted.
        #
        client use spnego principal = true
    
        #
        # Setting send spnego principal to yes .
        # Otherwise, it will not send this principal between Samba and Windows 2008
        #
        send spnego principal = Yes
    
        # If your Samba server only serves to Windows systems, try server signing = mandatory.
        server signing = auto
    
        template shell = /bin/bash
    
        winbind use default domain = Yes
    
        winbind enum users = No
        winbind enum groups = No
        winbind nested groups = Yes
    
        ignore syssetgroups error = No
        idmap uid = 1000 - 200000000
        idmap gid = 1000 - 200000000
    
        enable core files = false
        #  Disable Logging to syslog, and only write log to Samba standard log files.
        syslog = 0
    
        #
        # Suse CUPS printing appears to crash at start up
        # So we disable printing on this platform for now
        #
        printing = BSD
    #[samba-test]
    #    path = /samba-test
    #    public = yes
    
        #  if set  public = No, we should  set parameter valid users .
        #  and when the user or group is in AD , the setting syntaxes is:
        #  valid users = ****\username +****\group
    
    #    writable = yes
    
    
    [homes]
        comment = Home directories
        read only = No
        browseable = No
    
    [files]
        comment = drilled files
        path = /mnt/shares/files
    #    valid users = ****\hkashouli
        create mask = 777
        force create mode = 777
        directory mask = 777
        force directory mode = 777
        writable = yes
    Thanks
    There is no spoon...

  2. #2
    Join Date
    Apr 2005
    Location
    Redwood City, CA, USA
    Beans
    178
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Exclamation Re: Samba and passwords with special characters

    I am still having this issue in any distribution I'm trying this... surely there is a universal way of fixing it?

    No one has responded to my Samba query yet, on their mailing lists.
    There is no spoon...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •