Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Wine and skype 64-bit issues.

  1. #1
    Join Date
    Oct 2012
    Beans
    15

    Wine and skype 64-bit issues.

    I'm fairly new to ubuntu. I'm on 12.10 64-bit (I think?), and I've been trying to install wine. I run
    Code:
    sudo apt-get update && sudo apt-get install wine
    and get the result:

    The following packages have unmet dependencies:
    wine : Depends: wine1.4 but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    I get a similar message trying to install skype.

    The following packages have unmet dependencies:
    skype : Depends: skype-bin but it is not installable
    E: Unable to correct problems, you have held broken packages.

    I think this is a multiarch problem, but I don't yet know how to diagnose it.

  2. #2
    Join Date
    Jul 2012
    Beans
    603
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Wine and skype 64-bit issues.

    could be as I installed wine with software center on 12.10 64bit without problems but I had previously installed ia32 libs (or alike)

  3. #3
    Join Date
    Oct 2012
    Beans
    15

    Re: Wine and skype 64-bit issues.

    Quote Originally Posted by MikeCyber View Post
    could be as I installed wine with software center on 12.10 64bit without problems but I had previously installed ia32 libs (or alike)
    I tried that originally. I got and error like this:

    wine1.4: PreDepends: dpkg (>= 1.15.7.2~) but 1.16.7ubuntu6 is to be installed
    Depends: libc6 (>= 2.14) but 2.15-0ubuntu20 is to be installed
    Depends: wine1.4-amd64 (= 1.4.1-0ubuntu1) but 1.4.1-0ubuntu1 is to be installed
    Depends: wine1.4-i386 (= 1.4.1-0ubuntu1) but it is not going to be installed

  4. #4
    Join Date
    Oct 2012
    Location
    Catalunya
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wine and skype 64-bit issues.

    Try running this command:
    Code:
    sudo apt-get -f install
    And then run again:
    Code:
    sudo apt-get update && sudo apt-get install wine

  5. #5
    Join Date
    Oct 2012
    Beans
    15

    Re: Wine and skype 64-bit issues.

    Quote Originally Posted by COMECON View Post
    Try running this command:
    Code:
    sudo apt-get -f install
    And then run again:
    Code:
    sudo apt-get update && sudo apt-get install wine
    I tried this. Doesn't appear to change anything.

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  6. #6
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wine and skype 64-bit issues.

    Try:

    sudo apt-get build-dep wine

  7. #7
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wine and skype 64-bit issues.

    Now I want to ask about the 2nd part of the title of this thread: are you installing wine to run Skype? If so, you don't need to. Just install the native Skype package from the software center or using synaptic package manager.

  8. #8
    Join Date
    Oct 2012
    Beans
    15

    Re: Wine and skype 64-bit issues.

    Quote Originally Posted by squakie View Post
    Now I want to ask about the 2nd part of the title of this thread: are you installing wine to run Skype? If so, you don't need to. Just install the native Skype package from the software center or using synaptic package manager.
    I tried both of those.

    Code:
    Package dependencies cannot be resolved
    
    The following packages have unmet dependencies:
    
    skype: Depends: skype-bin but it is not going to be installed
    Synaptic gives me "Could not apply changes! Fix broken packages first."

    Also,

    Code:
    athquiz@ubuntu:~$ sudo apt-get build-dep wine
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Picking 'wine1.4' as source package instead of 'wine'
    E: Unable to find a source package for wine1.4

  9. #9
    squakie is offline I Ubuntu, Therefore, I Am
    Join Date
    Oct 2012
    Beans
    2,238
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wine and skype 64-bit issues.

    In synaptic, did you try clicking on "edit" up on the top bar and then "fix broken packages" in the drop down? What does it say?

    Somehow I also wonder if there isn't somehow a mismatch with something 64-bit versus something 32-bit. So, you are running 64-bit Ubuntu, correct? Have you tried manually installing something that perhaps you used the 32-bit name instead of the 64-bit name?

  10. #10
    Join Date
    Oct 2012
    Beans
    15

    Re: Wine and skype 64-bit issues.

    Quote Originally Posted by squakie View Post
    In synaptic, did you try clicking on "edit" up on the top bar and then "fix broken packages" in the drop down? What does it say?

    Somehow I also wonder if there isn't somehow a mismatch with something 64-bit versus something 32-bit. So, you are running 64-bit Ubuntu, correct? Have you tried manually installing something that perhaps you used the 32-bit name instead of the 64-bit name?
    I just "fixed broken packages" in synaptic. Not sure if it did anything. I also tried:
    Code:
    sudo apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    I've tried both the 32 bit and 64 bit versions of both of these, but it seems that the 64 bit has a dependency for the 32 bit version. Results for wine:

    Code:
    athquiz@ubuntu:~$ sudo apt-get install wine1.4-amd64
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     wine1.4-amd64 : Depends: wine1.4-common (= 1.4.1-0ubuntu1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    athquiz@ubuntu:~$ sudo apt-get install wine1.4-common
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     wine1.4-common : Depends: wine1.4 (= 1.4.1-0ubuntu1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    athquiz@ubuntu:~$ sudo apt-get install wine1.4
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     wine1.4 : Depends: wine1.4-i386 (= 1.4.1-0ubuntu1) but it is not installable
               Recommends: gnome-exe-thumbnailer but it is not going to be installed or
                           kde-runtime but it is not going to be installed
               Recommends: ttf-droid
               Recommends: ttf-mscorefonts-installer but it is not going to be installed
               Recommends: ttf-umefont but it is not going to be installed
               Recommends: ttf-unfonts-core but it is not going to be installed
               Recommends: winbind but it is not going to be installed
               Recommends: winetricks but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •