Results 1 to 2 of 2

Thread: 12.04 - Minecraft crashes and logs out of Unity

  1. #1
    Join Date
    Jan 2009

    Question [SOLVED] 12.04 - Minecraft crashes and logs out of Unity

    Background: This recently started happening only after I installed some updates or possibly after I installed jDownloader.

    What happens? I run Minecraft and can get to the login page, but after logging in and seeing the Mojang logo my screen goes black and sends me back to the login screen.

    Output of dmesg:
    [139320.407817] [fglrx] IRQ 44 Disabled
    [139320.881792] fglrx_pci 0000:01:00.0: irq 44 for MSI/MSI-X
    [139320.883514] [fglrx] Firegl kernel thread PID: 30509
    [139320.883716] [fglrx] Firegl kernel thread PID: 30510
    [139320.883927] [fglrx] Firegl kernel thread PID: 30511
    [139320.884209] [fglrx] IRQ 44 Enabled
    [139321.072416] [fglrx] Gart USWC size:1280 M.
    [139321.072419] [fglrx] Gart cacheable size:508 M.
    [139321.072422] [fglrx] Reserved FB block: Shared offset:0, size:1000000 
    [139321.072424] [fglrx] Reserved FB block: Unshared offset:fbfd000, size:403000 
    [139321.072425] [fglrx] Reserved FB block: Unshared offset:3fff4000, size:c000
    And output of the crash report:
    # A fatal error has been detected by the Java Runtime Environment:
    #  SIGSEGV (0xb) at pc=0x00007f917dcded90, pid=30426, tid=140263097546496
    # JRE version: 6.0_24-b24
    # Java VM: OpenJDK 64-Bit Server VM (20.0-b12 mixed mode linux-amd64 compressed oops)
    # Derivative: IcedTea6 1.11.5
    # Distribution: Ubuntu 12.04 LTS, package 6b24-1.11.5-0ubuntu1~12.04.1
    # Problematic frame:
    # C  []  xcb_glx_gen_queries_arb_data_length+0x0
    # If you would like to submit a bug report, please include
    # instructions how to reproduce the bug and visit:
    # The crash happened outside the Java Virtual Machine in native code.
    # See problematic frame for where to report the bug.
    ---------------  T H R E A D  ---------------
    Current thread (0x00007f9120036000):  JavaThread "Minecraft main thread" daemon [_thread_in_native, id=30461, stack(0x00007f918c0ab000,0x00007f918c1ac000)]
    siginfo:si_signo=SIGSEGV: si_errno=0, si_code=1 (SEGV_MAPERR), si_addr=0x0000000000000004
    RAX=0x0000000000000000, RBX=0x0000000000000000, RCX=0x0000000000000000, RDX=0x00007f9118018808
    RSP=0x00007f918c1aa438, RBP=0x00007f91184aa000, RSI=0x0000000000000000, RDI=0x0000000000000000
    R8 =0x00007f9118018830, R9 =0x0000000000000000, R10=0x00007f918c1aa1d0, R11=0x00007f917dcded90
    R12=0x00007f911803f6c0, R13=0x0000000000009080, R14=0x00007f918c1aa520, R15=0x00007f9120036000
    RIP=0x00007f917dcded90, EFLAGS=0x0000000000010202, CSGSFS=0x0000000000000033, ERR=0x0000000000000004
    Top of Stack: (sp=0x00007f918c1aa438)
    0x00007f918c1aa438:   00007f917e33d03f 00000006fc750270
    0x00007f918c1aa448:   00000006fc750270 00007f918c1aa4e0
    0x00007f918c1aa458:   0000000000000000 00000006fc750270
    0x00007f918c1aa468:   00007f919d010d68 00007f916411bfa0
    0x00007f918c1aa478:   00007f916411bfa0 00000006fffffffe
    0x00007f918c1aa488:   0000000000000000 00000006fc4bb880
    0x00007f918c1aa498:   0000000000000000 00007f918c1aa4a0
    0x00007f918c1aa4a8:   00000006fc750270 00007f918c1aa520
    0x00007f918c1aa4b8:   00000006fc7518e0 0000000000000000
    0x00007f918c1aa4c8:   00000006fc750270 0000000000000000
    0x00007f918c1aa4d8:   00007f918c1aa500 00007f918c1aa568
    0x00007f918c1aa4e8:   00007f919d00585a 00000006fc751878
    0x00007f918c1aa4f8:   00007f919d00df58 00007f917e0f49e0
    0x00007f918c1aa508:   00007f918c1aa568 00007f91184aa000
    0x00007f918c1aa518:   00000007aed90e08 0000000000009080
    0x00007f918c1aa528:   00007f918c1aa528 00000006fc75017a
    0x00007f918c1aa538:   00007f918c1aa590 00000006fc7518e0
    0x00007f918c1aa548:   0000000000000000 00000006fc7501b0
    0x00007f918c1aa558:   00007f918c1aa500 00007f918c1aa590
    0x00007f918c1aa568:   00007f918c1aa5d8 00007f919d00585a
    0x00007f918c1aa578:   00007f917e0f49e0 0000000000000000
    0x00007f918c1aa588:   00000007ad7d8228 00000007aed90e08
    0x00007f918c1aa598:   00007f918c1aa598 00000006fc72f015
    0x00007f918c1aa5a8:   00007f918c1aa638 00000006fc74b250
    0x00007f918c1aa5b8:   0000000000000000 00000006fc72f210
    0x00007f918c1aa5c8:   00007f918c1aa590 00007f918c1aa628
    0x00007f918c1aa5d8:   00007f918c1aa690 00007f919d00585a
    0x00007f918c1aa5e8:   0000000000000000 0000000000000000
    0x00007f918c1aa5f8:   0000000000000000 0000000000000000
    0x00007f918c1aa608:   0000000000000000 0000000000000000
    0x00007f918c1aa618:   0000000000000020 0000000000000022
    0x00007f918c1aa628:   00000007ad970b60 00000007b04c0d48 
    Instructions: (pc=0x00007f917dcded90)
    0x00007f917dcded70:   0c a1 ff ff 48 83 c4 58 c3 0f 1f 80 00 00 00 00
    0x00007f917dcded80:   48 8d 47 20
    Let me know if I can provide any more information.

    AMD Phenom II X6 1055T
    SAPPHIRE Radeon HD 6870 1GB 256-bit GDDR5

    edit: I may have accidentally updated the kernel and it's also possible that my graphics drivers were built manually. I'm going to try uninstalling reinstalling/updating.

    edit #2: uninstalling the previous fglrx drivers and installing new ones worked (updated catalyst to 12.10 while I was at it). It actually solved a plethora of other issues I was ignoring too, like Steam looking buggy etc etc.
    Last edited by keenanv; October 29th, 2012 at 01:13 AM.

  2. #2
    Join Date
    Oct 2012

    Re: 12.04 - Minecraft crashes and logs out of Unity

    You probably need to re install your graphics card drivers.

    This has happened to me multiple times after installing updates and that always seems to fix the problem.

    Radeon hd 7770
    ati catalyst 12.10

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts