I'm quite the noob when it comes to getting into the guts of Ubuntu.

I am ultimately trying to get VirtualBox to work...

From all the Googling I have done I have found the problem but have no idea how to fix it.

Apparently the kernel headers are missing from my system. The error that I get is
Error! Your kernel headers for kernel 3.0.0-17-generic cannot be found.
Please install the linux-headers-3.0.0-17-generic package,
or use the --kernelsourcedir option to tell DKMS where it's located
I ran the following command to confirm the kernel that is running.

/etc/init.d$ uname -r
That looked good.

I tried to install these headers...
/etc/init.d$ sudo apt-get install linux-headers-$(uname -r) gcc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package linux-headers-3.0.0-17-generic
E: Couldn't find any package by regex 'linux-headers-3.0.0-17-generic'
When I look in Synaptic package manager it is showing that I have 3.2 Linux headers up to 3.2.0-30. OK, this is confusing.

When I look at the Ubuntu Wiki is says that 12.04 has kernel 3.2.14. Hmmm.

So I am pretty confused about what to do.

Any help would be greatly appreciated.