Results 1 to 3 of 3

Thread: Error with dpkg, dealing with JDK7 and OpenMPI

  1. #1
    Join Date
    Sep 2009
    Beans
    67
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Error with dpkg, dealing with JDK7 and OpenMPI

    I am running 12.04, and am able to run java just fine. My programs which I write compile and run in java without error. Just in case it is needed the output to java -version is:

    Code:
     java version "1.7.0_05"
    Java(TM) SE Runtime Environment (build 1.7.0_05-b05)
    Java HotSpot(TM) Client VM (build 23.1-b03, mixed mode)
    I am trying to install OpenMPI and configure it on my system. I have the correct compilers, but when I run
    Code:
    sudo apt-get install libopenmpi-dev openmpi-bin openmpi-doc
    I get the following error:

    Errors were encountered while processing:
    oracle-java7-installer
    E: Sub-process /usr/bin/dpkg returned an error code (1)


    The strange thing is, is that when I try to update (which should be done weekly), I get the exact same error. I have looked in my logs, but am a bit lost as to what I should even be looking for. I have not updated in months, as I am completely unable to.

    I would like to be able to update, but more importantly I need o be able to download and install OpenMPI, as I am in a bit of a time crunch (by tomorrow) to get some other
    MPI related software up and running.

    I have tried reinstalling java but nothing seems to be doing the trick.

    Any help on the matter would be greatly appreciated!!

    Peace and Music

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    12,234
    Distro
    Xubuntu 16.04 Xenial Xerus

    Re: Error with dpkg, dealing with JDK7 and OpenMPI

    hi ! Damascushead ;

    You advise can not down load any updates ?
    Likely a dpkg configuration situation...
    let us look at what errors dpkg generates; post the results of terminal commands:
    Code:
    sudo apt-get update
    sudo apt-get upgrade
    see if we can get this squared-away
    warm regards <==BDQ

  3. #3
    Join Date
    Sep 2009
    Beans
    67
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Error with dpkg, dealing with JDK7 and OpenMPI

    Ok I just solved the problem. The following codes fixed it:

    Code:
    sudo rm /var/lib/dpkg/info/oracle-java7-installer*
    sudo apt-get purge oracle-java7-installer*
    sudo rm /etc/apt/sources.list.d/*java*
    sudo apt-get update
    I ran them right before I did a fresh install of Java 7.

    I am not sure how I would have intrinsically known which files to look in for these removals to be made, but now the error is gone, and I have successfully installed OpenMPI. Even though I don't know why these files fixed the problem

    Thank you for offering to help though. There is always great help on these forums!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •