Results 1 to 6 of 6

Thread: Can't access shared folder in VBox

  1. #1
    Join Date
    Feb 2010
    Location
    Land of Confusion
    Beans
    8,429
    Distro
    Ubuntu 16.04 Xenial Xerus

    Can't access shared folder in VBox

    Host: Windows 7 Pro
    Client: Ubuntu 12.04
    VM software: VirtualBox
    Guest additions: installed
    Shared directory: E:\ubuntushare (NTFS)
    NTFS folder permissions: Everyone = full control

    I can see the shared folder in ubuntu, but I can't do anything with it. When I try, I get,
    You do not have the permissions necessary to view the contents of "sf_ubuntushare".
    I have tried chowning it, but that does not change the permissions visible in ubuntu.

    What else can I do to get ubuntu to mount, preferably automatically, to this folder?

  2. #2

    Re: Can't access shared folder in VBox

    Host > Settings > Shared Folders > Double click the share
    Read-only and auto mount checked?
    Windows assumes the user is an idiot.
    Linux demands proof.

  3. #3
    Join Date
    May 2012
    Beans
    114
    Distro
    Ubuntu Development Release

    Re: Can't access shared folder in VBox

    Quote Originally Posted by uRock View Post
    Host: Windows 7 Pro
    Client: Ubuntu 12.04
    VM software: VirtualBox
    Guest additions: installed
    Shared directory: E:\ubuntushare (NTFS)
    NTFS folder permissions: Everyone = full control

    I can see the shared folder in ubuntu, but I can't do anything with it. When I try, I get, I have tried chowning it, but that does not change the permissions visible in ubuntu.

    What else can I do to get ubuntu to mount, preferably automatically, to this folder?
    From the VBox User Manual:

    Note

    Access to auto-mounted shared folders is only granted to the user group vboxsf, which is created by the VirtualBox Guest Additions installer. Hence guest users have to be member of that group to have read/write access or to have read-only access in case the folder is not mapped writable.
    Your user account in Ubuntu guest OS needs to be in the vboxsf group.

  4. #4
    Join Date
    Feb 2010
    Location
    Land of Confusion
    Beans
    8,429
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Can't access shared folder in VBox

    Quote Originally Posted by Habitual View Post
    Host > Settings > Shared Folders > Double click the share
    Read-only and auto mount checked?
    Yes.

    Quote Originally Posted by wheeze View Post
    From the VBox User Manual:



    Your user account in Ubuntu guest OS needs to be in the vboxsf group.
    Thanks! Next on my list is finding the correct command.
    Code:
    urock@uRock-ubuntu:~$ sudo adduser urock vboxsf
    [sudo] password for urock: 
    Adding user `urock' to group `vboxsf' ...
    Adding user urock to group vboxsf
    Done.
    Last edited by uRock; October 25th, 2012 at 01:19 AM.

  5. #5
    Join Date
    Feb 2010
    Location
    Land of Confusion
    Beans
    8,429
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Can't access shared folder in VBox

    Alright, that worked. Thanx!

  6. #6
    Join Date
    May 2012
    Beans
    114
    Distro
    Ubuntu Development Release

    Re: Can't access shared folder in VBox

    Quote Originally Posted by uRock View Post
    Alright, that worked. Thanx!
    Good to hear you got it sorted out.

    I always add gnome-system-tools to any installation I'm using to get a nice GUI for dealing with users, groups and things.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •