Results 1 to 5 of 5

Thread: Compatability between 10.04 and 12.04 libraries?

  1. #1
    Join Date
    Oct 2012
    Beans
    2

    Compatability between 10.04 and 12.04 libraries?

    Hi,

    I am new to Ubuntu (usually I administer Red Hat type Linux), so please bear with me if I have missed something obvious.

    I have been asked to upgrade the glibc, libglib, and pkg-config on my 10.04 server to the 12.04 versions. When I try to do this, I receive dependency errors. When I try to resolve those, I recieve more dependency errors. I have tried using apt-get (pointing to a 12.04 repository), as well as dpkg -i installing the actual .deb.files. I also tried synaptic. Still dependency errors.

    My question is, is this task possible or even wise? If it is possible, can someone please enlighten me

    Thank you in advance

  2. #2
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Compatability between 10.04 and 12.04 libraries?

    Possible, maybe.

    Wise, probably not.

    If you need the 12.04 versions of library's then your best solution is to run 12.04.
    Dependencies of some of the 12.04 library's may require other packages that are only available if you are running 12.04.
    Cheesemill

  3. #3
    Join Date
    Apr 2006
    Location
    Ubuntuland
    Beans
    2,124
    Distro
    Ubuntu 13.10 Saucy Salamander

    Lightbulb Re: Compatability between 10.04 and 12.04 libraries?

    Quote Originally Posted by Cheesemill View Post
    Possible, maybe.

    Wise, probably not.

    If you need the 12.04 versions of library's then your best solution is to run 12.04.
    Dependencies of some of the 12.04 library's may require other packages that are only available if you are running 12.04.
    I agree.... things are moving forward and the dependencies are too.
    24 beers in a case, 24 hours in a day. Coincidence? I think not!

    Trusty Tahr 64 bit, AMD Phenom II 955 Quad Core 3.2GHz, GeForce 9600 GT
    16G PC2-6400 RAM, 128 GB SSD, Twin 1TB SATA 7200 RPM RAID0

  4. #4
    Join Date
    Oct 2012
    Beans
    2

    Re: Compatability between 10.04 and 12.04 libraries?

    Thank you for the replies. I am required to stay at 10.04, so moving to another version (while I would love to), sadly is not an option for me.

  5. #5
    Join Date
    Apr 2006
    Location
    Ubuntuland
    Beans
    2,124
    Distro
    Ubuntu 13.10 Saucy Salamander

    Exclamation Re: Compatability between 10.04 and 12.04 libraries?

    Quote Originally Posted by dcannon View Post
    Thank you for the replies. I am required to stay at 10.04, so moving to another version (while I would love to), sadly is not an option for me.
    If that's your requirement, then that's what you have to do. But if you stay with a two and a half year old version you will have to give up something.
    24 beers in a case, 24 hours in a day. Coincidence? I think not!

    Trusty Tahr 64 bit, AMD Phenom II 955 Quad Core 3.2GHz, GeForce 9600 GT
    16G PC2-6400 RAM, 128 GB SSD, Twin 1TB SATA 7200 RPM RAID0

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •