Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: Broken packages on Ubuntu 12.04

  1. #21
    Join Date
    May 2007
    Beans
    314
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Broken packages on Ubuntu 12.04

    Do you have Synaptic Package Manager? Can you install and launch it? It could give you some clues.

  2. #22
    Join Date
    Oct 2012
    Beans
    18

    Re: Broken packages on Ubuntu 12.04

    Quote Originally Posted by AlexDudko View Post
    Do you have Synaptic Package Manager? Can you install and launch it? It could give you some clues.
    I don't have it and I cannot install anything from my Software Center anymore as well. It thinks the catalog is broken, if I try to 'repair', I get the same error as I've pasted.

    Any ideas?

  3. #23
    Join Date
    Apr 2010
    Beans
    212

    Re: Broken packages on Ubuntu 12.04

    What's going above is textbook on how to destroy an operation system by hand. Please stop any operation on libc6, it's the most lethal package of your system.

    Have you ever tried 'apt-get -f install' ?

  4. #24
    Join Date
    Oct 2012
    Beans
    18

    Re: Broken packages on Ubuntu 12.04

    Quote Originally Posted by funicorn View Post
    What's going above is textbook on how to destroy an operation system by hand. Please stop any operation on libc6, it's the most lethal package of your system.

    Have you ever tried 'apt-get -f install' ?
    Which I now regretfully realize. Though, I did say I didn't have any clue on what I was doing, I was pretty much just following instructions.

    `apt-get install -f` does not fix this mess, it just leads to more errors as can be seen here: http://paste.ubuntu.com/1294497/

    I spent some time in #ubuntu on Freenode, and the general consensus seemed to be the installation is royally screwed, and a re-install is in order, unless you have a solution?

  5. #25
    Join Date
    Mar 2009
    Beans
    3

    Re: Broken packages on Ubuntu 12.04

    I had more or less the same challenge. This worked for me:

    root@twosheds:/home/staalej# ls *deb
    libc6_2.15-0ubuntu10.2_i386.deb libc6-dev_2.15-0ubuntu10.2_i386.deb libc-bin_2.15-0ubuntu10.2_i386.deb libc-dev-bin_2.15-0ubuntu10.2_i386.deb
    root@twosheds:/home/staalej# dpkg -i *deb
    (Reading database ... 334533 files and directories currently installed.)
    Preparing to replace libc6 2.15-0ubuntu10.2 (using libc6_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc6 ...
    Preparing to replace libc6-dev 2.15-0ubuntu10.2 (using libc6-dev_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc6-dev ...
    dpkg: warning: downgrading libc-bin from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc-bin 2.15-0ubuntu10.3 (using libc-bin_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc-bin ...
    dpkg: warning: downgrading libc-dev-bin from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc-dev-bin 2.15-0ubuntu10.3 (using libc-dev-bin_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc-dev-bin ...
    Setting up libc-bin (2.15-0ubuntu10.2) ...
    Processing triggers for man-db ...
    Setting up libc6 (2.15-0ubuntu10.2) ...
    Setting up libc-dev-bin (2.15-0ubuntu10.2) ...
    Setting up libc6-dev (2.15-0ubuntu10.2) ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    root@twosheds:/home/staalej# apt-get install -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up build-essential (11.5ubuntu2.1) ...
    root@twosheds:/home/staalej# dpkg --configure -a
    root@twosheds:/home/staalej# apt-get clean
    root@twosheds:/home/staalej# apt-get autoclean
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    root@twosheds:/home/staalej#

    I downloaded the old versions of the libraries and installed
    them at the same time. This seems to have done the trick. I'm on a i386 system. The server just booted successfully, at least

    Best of luck,

    --
    Ståle

  6. #26
    Join Date
    Oct 2012
    Beans
    18

    Re: Broken packages on Ubuntu 12.04

    Quote Originally Posted by flipperwald View Post
    I had more or less the same challenge. This worked for me:

    root@twosheds:/home/staalej# ls *deb
    libc6_2.15-0ubuntu10.2_i386.deb libc6-dev_2.15-0ubuntu10.2_i386.deb libc-bin_2.15-0ubuntu10.2_i386.deb libc-dev-bin_2.15-0ubuntu10.2_i386.deb
    root@twosheds:/home/staalej# dpkg -i *deb
    (Reading database ... 334533 files and directories currently installed.)
    Preparing to replace libc6 2.15-0ubuntu10.2 (using libc6_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc6 ...
    Preparing to replace libc6-dev 2.15-0ubuntu10.2 (using libc6-dev_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc6-dev ...
    dpkg: warning: downgrading libc-bin from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc-bin 2.15-0ubuntu10.3 (using libc-bin_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc-bin ...
    dpkg: warning: downgrading libc-dev-bin from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc-dev-bin 2.15-0ubuntu10.3 (using libc-dev-bin_2.15-0ubuntu10.2_i386.deb) ...
    Unpacking replacement libc-dev-bin ...
    Setting up libc-bin (2.15-0ubuntu10.2) ...
    Processing triggers for man-db ...
    Setting up libc6 (2.15-0ubuntu10.2) ...
    Setting up libc-dev-bin (2.15-0ubuntu10.2) ...
    Setting up libc6-dev (2.15-0ubuntu10.2) ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    root@twosheds:/home/staalej# apt-get install -f
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
    1 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Setting up build-essential (11.5ubuntu2.1) ...
    root@twosheds:/home/staalej# dpkg --configure -a
    root@twosheds:/home/staalej# apt-get clean
    root@twosheds:/home/staalej# apt-get autoclean
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    root@twosheds:/home/staalej#

    I downloaded the old versions of the libraries and installed
    them at the same time. This seems to have done the trick. I'm on a i386 system. The server just booted successfully, at least

    Best of luck,

    --
    Ståle
    Thanks your input. So I should just grab the .deb files for all my packages that are broken? My apt-get install -f shows:

    Code:
    The following extra packages will be installed:
      libc6 libc6:i386 libc6-dev libc6-i386
    Suggested packages:
      glibc-doc glibc-doc:i386 locales:i386
    The following NEW packages will be installed:
      libc6-dev libc6-i386
    The following packages will be upgraded:
      libc6 libc6:i386
    What is the 'libc6:i386' package? I'm on a amd64 system, I'll try your approach and update. Thanks!

  7. #27
    Join Date
    Mar 2009
    Beans
    3

    Re: Broken packages on Ubuntu 12.04

    Quote Originally Posted by GVRV View Post
    Thanks your input. So I should just grab the .deb files for all my packages that are broken? My apt-get install -f shows:

    Code:
    The following extra packages will be installed:
      libc6 libc6:i386 libc6-dev libc6-i386
    Suggested packages:
      glibc-doc glibc-doc:i386 locales:i386
    The following NEW packages will be installed:
      libc6-dev libc6-i386
    The following packages will be upgraded:
      libc6 libc6:i386
    What is the 'libc6:i386' package? I'm on a amd64 system, I'll try your approach and update. Thanks!
    I'm not sure what that package is. Basically, I have the impression that dpkg will sort out the dependencies between all the packages on the command line. I suggest something like

    dpkg -i libc6 libc6-dev libc6-i386

    for the same generation of these packages. If dpkg is happy, they will install, otherwise it may tell you it wants another package also.

    --
    Ståle

  8. #28
    Join Date
    Oct 2012
    Beans
    18

    Re: Broken packages on Ubuntu 12.04

    Quote Originally Posted by flipperwald View Post
    I'm not sure what that package is. Basically, I have the impression that dpkg will sort out the dependencies between all the packages on the command line. I suggest something like

    dpkg -i libc6 libc6-dev libc6-i386

    for the same generation of these packages. If dpkg is happy, they will install, otherwise it may tell you it wants another package also.

    --
    Ståle
    Okay, that *seems* to have worked even though there were errors in there. I'll try updating and upgrading and installing a new package now to see if APT is really back to normal

    Code:
    (k3)gaurav@gaurav-gamma:~/Downloads$ ls libc*
    libc6_2.15-0ubuntu10.2_amd64.deb  libc6-dev_2.15-0ubuntu10.2_amd64.deb   libc-bin_2.15-0ubuntu10.2_amd64.deb
    libc6_2.15-0ubuntu10.2_i386.deb   libc6-i386_2.15-0ubuntu10.2_amd64.deb  libc-dev-bin_2.15-0ubuntu10.2_amd64.deb
    (k3)gaurav@gaurav-gamma:~/Downloads$ sudo dpkg -i libc*
    (Reading database ... 365946 files and directories currently installed.)
    Preparing to replace libc6 2.15-0ubuntu10.2 (using libc6_2.15-0ubuntu10.2_amd64.deb) ...
    dpkg: error processing libc6_2.15-0ubuntu10.2_amd64.deb (--install):
     subprocess new pre-installation script returned error exit status 1
    Preparing to replace libc6:i386 2.15-0ubuntu10.2 (using libc6_2.15-0ubuntu10.2_i386.deb) ...
    dpkg: error processing libc6_2.15-0ubuntu10.2_i386.deb (--install):
     subprocess new pre-installation script returned error exit status 1
    dpkg: warning: downgrading libc6-dev from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc6-dev 2.15-0ubuntu10.3 (using libc6-dev_2.15-0ubuntu10.2_amd64.deb) ...
    Unpacking replacement libc6-dev ...
    dpkg: warning: downgrading libc6-i386 from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc6-i386 2.15-0ubuntu10.3 (using libc6-i386_2.15-0ubuntu10.2_amd64.deb) ...
    Unpacking replacement libc6-i386 ...
    Replaced by files in installed package libc6:i386 ...
    dpkg: warning: downgrading libc-bin from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc-bin 2.15-0ubuntu10.3 (using libc-bin_2.15-0ubuntu10.2_amd64.deb) ...
    Unpacking replacement libc-bin ...
    dpkg: warning: downgrading libc-dev-bin from 2.15-0ubuntu10.3 to 2.15-0ubuntu10.2.
    Preparing to replace libc-dev-bin 2.15-0ubuntu10.3 (using libc-dev-bin_2.15-0ubuntu10.2_amd64.deb) ...
    Unpacking replacement libc-dev-bin ...
    Setting up libc6-i386 (2.15-0ubuntu10.2) ...
    Setting up libc-bin (2.15-0ubuntu10.2) ...
    Setting up libc-dev-bin (2.15-0ubuntu10.2) ...
    Setting up libc6-dev (2.15-0ubuntu10.2) ...
    Errors were encountered while processing:
     libc6_2.15-0ubuntu10.2_amd64.deb
     libc6_2.15-0ubuntu10.2_i386.deb
    (k3)gaurav@gaurav-gamma:~/Downloads$ sudo apt-get install -f 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 47 not upgraded.
    (k3)gaurav@gaurav-gamma:~/Downloads$ sudo dpkg --configure -a

  9. #29
    Join Date
    Oct 2012
    Beans
    18

    Re: Broken packages on Ubuntu 12.04

    Nope, upgrading fails and gives us the same error. Why is the 'libc6:i386' package update screwing up all the damn time?

    Code:
    (k3)gaurav@gaurav-gamma:~/Downloads$ sudo apt-get update
    Ign http://archive.ubuntu.com precise InRelease                                            
    Ign http://in.archive.ubuntu.com precise InRelease
    Ign http://in.archive.ubuntu.com precise-updates InRelease
    Hit http://archive.ubuntu.com precise Release.gpg
    Hit http://in.archive.ubuntu.com precise Release.gpg
    Hit http://archive.ubuntu.com precise Release
    Get:1 http://in.archive.ubuntu.com precise-updates Release.gpg [198 B]
    Hit http://archive.ubuntu.com precise/main Sources        
    Hit http://in.archive.ubuntu.com precise Release
    Hit http://archive.ubuntu.com precise/restricted Sources
    Get:2 http://in.archive.ubuntu.com precise-updates Release [49.6 kB]
    Hit http://in.archive.ubuntu.com precise/restricted Sources
    Hit http://in.archive.ubuntu.com precise/main Sources
    Hit http://in.archive.ubuntu.com precise/multiverse Sources
    Hit http://in.archive.ubuntu.com precise/universe Sources
    Hit http://in.archive.ubuntu.com precise/main amd64 Packages
    Hit http://in.archive.ubuntu.com precise/restricted amd64 Packages
    Hit http://in.archive.ubuntu.com precise/universe amd64 Packages
    Hit http://in.archive.ubuntu.com precise/multiverse amd64 Packages
    Hit http://in.archive.ubuntu.com precise/main i386 Packages
    Hit http://in.archive.ubuntu.com precise/restricted i386 Packages
    Hit http://in.archive.ubuntu.com precise/universe i386 Packages
    Hit http://in.archive.ubuntu.com precise/multiverse i386 Packages
    Hit http://in.archive.ubuntu.com precise/main TranslationIndex
    Hit http://in.archive.ubuntu.com precise/multiverse TranslationIndex
    Hit http://in.archive.ubuntu.com precise/restricted TranslationIndex
    Hit http://in.archive.ubuntu.com precise/universe TranslationIndex
    Get:3 http://in.archive.ubuntu.com precise-updates/restricted Sources [4,395 B]                                                                    
    Get:4 http://in.archive.ubuntu.com precise-updates/main Sources [179 kB]                                                                           
    Get:5 http://in.archive.ubuntu.com precise-updates/multiverse Sources [4,745 B]                                                                    
    Get:6 http://in.archive.ubuntu.com precise-updates/universe Sources [60.2 kB]                                                                      
    Get:7 http://in.archive.ubuntu.com precise-updates/main amd64 Packages [406 kB]                                                                    
    Get:8 http://in.archive.ubuntu.com precise-updates/restricted amd64 Packages [8,215 B]                                                             
    Get:9 http://in.archive.ubuntu.com precise-updates/universe amd64 Packages [149 kB]                                                                
    Get:10 http://in.archive.ubuntu.com precise-updates/multiverse amd64 Packages [8,948 B]                                                            
    Get:11 http://in.archive.ubuntu.com precise-updates/main i386 Packages [412 kB]                                                                    
    Get:12 http://in.archive.ubuntu.com precise-updates/restricted i386 Packages [8,218 B]                                                             
    Get:13 http://in.archive.ubuntu.com precise-updates/universe i386 Packages [150 kB]                                                                
    Get:14 http://in.archive.ubuntu.com precise-updates/multiverse i386 Packages [9,930 B]                                                             
    Hit http://in.archive.ubuntu.com precise-updates/main TranslationIndex                                                                             
    Hit http://in.archive.ubuntu.com precise-updates/multiverse TranslationIndex                                                                       
    Hit http://in.archive.ubuntu.com precise-updates/restricted TranslationIndex                                                                       
    Hit http://in.archive.ubuntu.com precise-updates/universe TranslationIndex                                                                         
    Hit http://in.archive.ubuntu.com precise/main Translation-en                                                                                       
    Hit http://in.archive.ubuntu.com precise/multiverse Translation-en                                                                                 
    Hit http://in.archive.ubuntu.com precise/restricted Translation-en                                                                                 
    Hit http://in.archive.ubuntu.com precise/universe Translation-en                                                                                   
    Hit http://in.archive.ubuntu.com precise-updates/main Translation-en                                                                               
    Hit http://in.archive.ubuntu.com precise-updates/multiverse Translation-en                                                                         
    Hit http://in.archive.ubuntu.com precise-updates/restricted Translation-en                                                                         
    Hit http://in.archive.ubuntu.com precise-updates/universe Translation-en                                                                           
    Fetched 1,451 kB in 18s (76.9 kB/s)                                                                                                                
    Reading package lists... Done
    (k3)gaurav@gaurav-gamma:~/Downloads$ 
    (k3)gaurav@gaurav-gamma:~/Downloads$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be upgraded:
      apparmor apport apport-gtk apport-symptoms apt apt-transport-https apt-utils aptdaemon aptdaemon-data libapt-inst1.4 libapt-pkg4.12 libc-bin
      libc-dev-bin libc6 libc6:i386 libc6-dev libc6-i386 libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa
      libglapi-mesa:i386 libglu1-mesa libglu1-mesa:i386 libldap-2.4-2 libldap-2.4-2:i386 libparted0debian1 libxatracker1 lsb-base lsb-release
      multiarch-support onboard parted passwd python-apport python-aptdaemon python-aptdaemon.gtk3widgets python-aptdaemon.pkcompat
      python-problem-report sessioninstaller update-notifier update-notifier-common wpasupplicant x11-utils xserver-xorg-input-wacom
      xserver-xorg-video-intel
    47 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 22.0 MB/30.6 MB of archives.
    After this operation, 37.9 kB of additional disk space will be used.
    Do you want to continue [Y/n]? 
    Get:1 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libc-bin amd64 2.15-0ubuntu10.3 [1,181 kB]
    Get:2 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libc6-i386 amd64 2.15-0ubuntu10.3 [3,993 kB]                                       
    Get:3 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libc-dev-bin amd64 2.15-0ubuntu10.3 [84.5 kB]                                      
    Get:4 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libc6-dev amd64 2.15-0ubuntu10.3 [2,945 kB]                                        
    Get:5 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libapt-pkg4.12 amd64 0.8.16~exp12ubuntu10.5 [939 kB]                               
    Get:6 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main apt amd64 0.8.16~exp12ubuntu10.5 [1,100 kB]                                        
    Get:7 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libapt-inst1.4 amd64 0.8.16~exp12ubuntu10.5 [99.8 kB]                              
    Get:8 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main lsb-base all 4.0-0ubuntu20.2 [10.4 kB]                                             
    Get:9 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main apparmor amd64 2.7.102-0ubuntu3.2 [357 kB]                                         
    Get:10 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libldap-2.4-2 i386 2.4.28-1.1ubuntu4.2 [186 kB]                                   
    Get:11 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libldap-2.4-2 amd64 2.4.28-1.1ubuntu4.2 [186 kB]                                  
    Get:12 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libparted0debian1 amd64 2.3-8ubuntu5.1 [240 kB]                                   
    Get:13 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libgl1-mesa-dri amd64 8.0.4-0ubuntu0.1 [3,056 kB]                                 
    Get:14 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libgl1-mesa-dri i386 8.0.4-0ubuntu0.1 [3,098 kB]                                  
    Get:15 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libgl1-mesa-glx i386 8.0.4-0ubuntu0.1 [103 kB]                                    
    Get:16 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libgl1-mesa-glx amd64 8.0.4-0ubuntu0.1 [104 kB]                                   
    Get:17 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libglapi-mesa amd64 8.0.4-0ubuntu0.1 [21.1 kB]                                    
    Get:18 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libglapi-mesa i386 8.0.4-0ubuntu0.1 [21.1 kB]                                     
    Get:19 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libxatracker1 amd64 8.0.4-0ubuntu0.1 [351 kB]                                     
    Get:20 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main update-notifier amd64 0.119ubuntu8.6 [57.3 kB]                                    
    Get:21 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main update-notifier-common all 0.119ubuntu8.6 [222 kB]                                
    Get:22 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libglu1-mesa i386 8.0.4-0ubuntu0.1 [165 kB]                                       
    Get:23 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main libglu1-mesa amd64 8.0.4-0ubuntu0.1 [161 kB]                                      
    Get:24 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main multiarch-support amd64 2.15-0ubuntu10.3 [4,480 B]                                
    Get:25 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main passwd amd64 1:4.1.4.2+svn3283-3ubuntu5.1 [959 kB]                                
    Get:26 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main apt-utils amd64 0.8.16~exp12ubuntu10.5 [190 kB]                                   
    Get:27 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main lsb-release all 4.0-0ubuntu20.2 [10.8 kB]                                         
    Get:28 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main apt-transport-https amd64 0.8.16~exp12ubuntu10.5 [16.3 kB]                        
    Get:29 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main parted amd64 2.3-8ubuntu5.1 [52.4 kB]                                             
    Get:30 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main python-problem-report all 2.0.1-0ubuntu14 [9,882 B]                               
    Get:31 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main python-apport all 2.0.1-0ubuntu14 [79.6 kB]                                       
    Get:32 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main apport all 2.0.1-0ubuntu14 [145 kB]                                               
    Get:33 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main apport-gtk all 2.0.1-0ubuntu14 [9,224 B]                                          
    Get:34 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main apport-symptoms all 0.16.1 [14.2 kB]                                              
    Get:35 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main onboard amd64 0.97.0-0ubuntu4 [406 kB]                                            
    Get:36 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main wpasupplicant amd64 0.7.3-6ubuntu2.1 [490 kB]                                     
    Get:37 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main x11-utils amd64 7.6+4ubuntu0.1 [230 kB]                                           
    Get:38 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-input-wacom amd64 1:0.14.0-0ubuntu2.1 [88.0 kB]                      
    Get:39 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main xserver-xorg-video-intel amd64 2:2.17.0-1ubuntu4.2 [238 kB]                       
    Get:40 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main aptdaemon-data all 0.43+bzr805-0ubuntu5 [164 kB]                                  
    Get:41 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main python-aptdaemon.gtk3widgets all 0.43+bzr805-0ubuntu5 [14.9 kB]                   
    Get:42 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main python-aptdaemon.pkcompat all 0.43+bzr805-0ubuntu5 [29.1 kB]                      
    Get:43 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main aptdaemon all 0.43+bzr805-0ubuntu5 [14.7 kB]                                      
    Get:44 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main python-aptdaemon all 0.43+bzr805-0ubuntu5 [82.5 kB]                               
    Get:45 http://in.archive.ubuntu.com/ubuntu/ precise-updates/main sessioninstaller all 0.20+bzr128-0ubuntu1.2 [29.7 kB]                             
    Fetched 22.0 MB in 3min 10s (115 kB/s)                                                                                                             
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    apparmor failed to preconfigure, with exit status 1
    (Reading database ... 365946 files and directories currently installed.)
    Preparing to replace libc-bin 2.15-0ubuntu10.2 (using .../libc-bin_2.15-0ubuntu10.3_amd64.deb) ...
    Unpacking replacement libc-bin ...
    Setting up libc-bin (2.15-0ubuntu10.3) ...
    (Reading database ... 365946 files and directories currently installed.)
    Preparing to replace libc6-i386 2.15-0ubuntu10.2 (using .../libc6-i386_2.15-0ubuntu10.3_amd64.deb) ...
    Unpacking replacement libc6-i386 ...
    Replaced by files in installed package libc6:i386 ...
    Preparing to replace libc-dev-bin 2.15-0ubuntu10.2 (using .../libc-dev-bin_2.15-0ubuntu10.3_amd64.deb) ...
    Unpacking replacement libc-dev-bin ...
    Preparing to replace libc6-dev 2.15-0ubuntu10.2 (using .../libc6-dev_2.15-0ubuntu10.3_amd64.deb) ...
    Unpacking replacement libc6-dev ...
    Preparing to replace libc6 2.15-0ubuntu10.2 (using .../libc6_2.15-0ubuntu10.3_amd64.deb) ...
    De-configuring libc6:i386 ...
    dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_amd64.deb (--unpack):
     subprocess new pre-installation script returned error exit status 1
    Preparing to replace libc6:i386 2.15-0ubuntu10.2 (using .../libc6_2.15-0ubuntu10.3_i386.deb) ...
    De-configuring libc6 ...
    dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_i386.deb (--unpack):
     subprocess new pre-installation script returned error exit status 1
    Errors were encountered while processing:
     /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_amd64.deb
     /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    (k3)gaurav@gaurav-gamma:~/Downloads$ 
    (k3)gaurav@gaurav-gamma:~/Downloads$ sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      libc6 libc6:i386
    Suggested packages:
      glibc-doc glibc-doc:i386 locales:i386
    The following packages will be upgraded:
      libc6 libc6:i386
    2 upgraded, 0 newly installed, 0 to remove and 41 not upgraded.
    3 not fully installed or removed.
    Need to get 0 B/8,593 kB of archives.
    After this operation, 8,192 B of additional disk space will be used.
    Do you want to continue [Y/n]? 
    Preconfiguring packages ...
    (Reading database ... 365946 files and directories currently installed.)
    Preparing to replace libc6 2.15-0ubuntu10.2 (using .../libc6_2.15-0ubuntu10.3_amd64.deb) ...
    De-configuring libc6:i386 ...
    dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_amd64.deb (--unpack):
     subprocess new pre-installation script returned error exit status 1
    No apport report written because MaxReports is reached already
                                                                  Preparing to replace libc6:i386 2.15-0ubuntu10.2 (using .../libc6_2.15-0ubuntu10.3_i386.deb) ...
    De-configuring libc6 ...
    dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_i386.deb (--unpack):
     subprocess new pre-installation script returned error exit status 1
    No apport report written because MaxReports is reached already
                                                                  Errors were encountered while processing:
     /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_amd64.deb
     /var/cache/apt/archives/libc6_2.15-0ubuntu10.3_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  10. #30
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Broken packages on Ubuntu 12.04

    its due to multiarch actual config, dont worry. But i feel like you have pushed the bigest mess there, and i doubt you will get it working back smootly now

    if you still want to try fixing it before doing a fresh clean reinstall, then try:

    sudo apt-get install --reinstall dpkg gcc cpp udev ubuntu-desktop

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •