I have successfully installed mobile broadband on 12.04 before - but cannot achieve it this time!

I have a o2 (UK) mobile broadband dongle.

My lsusb shows:

Bus 003 Device 003: ID 1bbb:f017 T & A Mobile Phones
T & A is, apparently, Alcatel. I'm pretty sure that the last time I used a different dongle with o2 it was Huawei.

Dmesg shows:

94.930167] usb 3-4: new high-speed USB device number 3 using xhci_hcd
[   94.949397] usb 3-4: New USB device found, idVendor=1bbb, idProduct=f017
[   94.949403] usb 3-4: New USB device strings: Mfr=3, Product=2, SerialNumber=4
[   94.949406] usb 3-4: Product: HSPA Data Card
[   94.949408] usb 3-4: Manufacturer: USBModem
[   94.949410] usb 3-4: SerialNumber: 1234567890ABCDEF
[   94.955314] scsi7 : usb-storage 3-4:1.0
[   95.954682] scsi 7:0:0:0: Direct-Access     ALCATEL  Mass Storage     2.31 PQ: 0 ANSI: 2
[   95.955336] scsi 7:0:0:1: CD-ROM            ALCATEL  Mass Storage     2.31 PQ: 0 ANSI: 2
[   95.956463] sd 7:0:0:0: Attached scsi generic sg2 type 0
[   95.960985] sr0: scsi-1 drive
[   95.961148] sr 7:0:0:1: Attached scsi CD-ROM sr0
[   95.961452] sr 7:0:0:1: Attached scsi generic sg3 type 5
[   95.968021] sd 7:0:0:0: [sdc] Attached SCSI removable disk
As we can see, the problem is that Ubuntu detects it as a mass storage device rather than mobile broadband.

I have so far checked that usb_modeswitch is installed and edited my /etc/modules to:

usbserial vendor=0x1bbb product=0xf017
However, this does not change anything. The main issue is that Network Manager does not display an option in the menu for mobile broadband. Only "wired", "wireless", and "VPN" are shown.

I have created a new connection for the mobile broadband with the correct APN and password but his does not change anything.

How can I make Ubuntu recognise my Alcatel / o2 mobile broadband as a mobile broadband and not as a mass storage device?

I need to get the Network Manager to show the "mobile broadband" connection (as I have done on this machine before without needing to mess around with /etc/modules and suchlike).

Many thanks!