Quote Originally Posted by rtimai View Post
RS880M [Mobility Radeon HD 4200 Series]

I clean-reinstalled 12.10 and am running the OSS driver (and yes, cpu a little hotter.) Downgrading X.org and fglrx, and possible the kernel is all too scary for me, as I don't know how it will effect updates and the next ubuntu upgrade.

All these video driver issues stem from Canonical's decision to transition from X.org to the new Wayland video server:


Not great news for those trying to hang on and keep older hardware running. I think I remember seeing somewhere that AMD was not planning to continue to support radeon 2xxx-4xxx in their fglrx driver. I may eventually have to switch to a more legacy-friendly distro.
I run a compaq presario cq61 with a HD radeon 4200 and the open-source drivers. Occasionally Ubuntu 12.10 will not boot and I have to go to recovery mode. I then thought I should switch to the proprietary drivers, but because the legacy drivers are not supported in ubuntu 12.10, I followed the procedure highlighted above (with ppa:makson96/fglrx-legacy).

It did not work at all. The system would hang on a black screen when I tried to boot. The usual trick of setting radeon.modeset=0 would not work. I had to go to recovery mode, drop to root shell, purge the fglrx-legacy package and reinstall xorg to restore a working system.

At least, as a newbie in Ubuntu, this gave me a nice training opportunity!!