Page 6 of 6 FirstFirst ... 456
Results 51 to 54 of 54

Thread: Ubuntu 12.10 Desktop does not show when I install nvidia drivers

  1. #51
    Join Date
    Oct 2009
    Location
    New York
    Beans
    59
    Distro
    Ubuntu Development Release

    Re: Ubuntu 12.10 Desktop does not shows when i installed nvidia drivers!

    [QUOTE=Lisiano;12307233]Don't install nVidia drivers for Intel GPUs. Same goes for ATI. If you mean you have an onboard Intel GPU AND a separate (discrete) nVidia GPU, you will have to stick to nouveau since using proprietary drivers blocks off access to other GPU drivers.

    5 years ago ubuntu worked fine with Nvidia drivers on a laptop with an Nvidia card - however it seems increasingly common today to see laptops who have Nvidia cards to come bundled with a Intel GPU - I wish to code opengl 4.x using my laptop which has a 4.x capable Nvidia card + Intel GPU - so you are saying I need to wait until nouveau handles OpenGL 4.x ? seems strange linux is behind M$ windows regarding Nvidia card coverage.

  2. #52
    Join Date
    Mar 2009
    Location
    Denmark
    Beans
    23
    Distro
    Ubuntu

    Re: Ubuntu 12.10 Desktop does not show when I install nvidia drivers

    Oops, forgot to update this here:

    I recently installed BumbleBee (https://wiki.ubuntu.com/Bumblebee#Installation), and everything just worked out of the box, meaning with Optimus enabled in BIOS.

    I just followed steps 1-5 in the link above, nothing else. This is on a Ubuntu 12.10 x64 installation on a Lenovo W520 laptop (Intel/NVidia Quadro 2000M).

  3. #53
    Join Date
    Dec 2008
    Beans
    9

    Re: Ubuntu 12.10 Desktop does not show when I install nvidia drivers

    For those who still got stuck with a broken Unity even when you're sure your Nvidia/ATI driver's now correct: I noticed that under another user account, evrything was fine, so it must be a user setting that got broken during the driver installations.

    After doing 'dconf reset -f /org/compiz' the problem was solved (just had to reconfigure some compiz settings).

  4. #54
    Join Date
    Jun 2013
    Beans
    1

    Re: Ubuntu 12.10 Desktop does not show when I install nvidia drivers

    OK, I know this issue has been mentioned and solved, but in my case all solutions which I found aren't working.

    I have Acer V3 with Geforce 730M and xubuntu 13.04 on it. I want to install drivers from Nvidia for my graphic card. What i did:
    1. Installed linux-headers, linux-source, reinstalled nvidia-current and nvidia-current-updates (http://ubuntuforums.org/showthread.php?t=2081649&page=2).
    2. Did nvidia-xconfig. After rebooting I couldn't change resolution from 640x480, moreover nvidia-xconfig gave an error
    Code:
    VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
     At least one Device section is required.
    3.Tried jockey-kde, failed after clicking "turn on", in log i found:
    Code:
    Traceback (most recent call last):
     File "/usr/lib/python2.7/dist-packages/jockey/detection.py", line 950, in get_handlers
     execfile(mod, symb)
     File "/usr/share/jockey/handlers/nvidia.py", line 12, in <module>
     from NvidiaDetector.nvidiadetector import NvidiaDetection
     ImportError: No module named NvidiaDetector.nvidiadetector
     2013-06-23 16:38:07,981 DEBUG: loading custom handler /usr/
    Code:
    2013-06-23 16:38:08,071 WARNING: Invalid custom handler module /usr/share/jockey/handlers/fglrx.py
     Traceback (most recent call last):
     File "/usr/lib/python2.7/dist-packages/jockey/detection.py", line 950, in get_handlers
     execfile(mod, symb)
     File "/usr/share/jockey/handlers/fglrx.py", line 11, in <module>
     from NvidiaDetector.alternatives import Alternatives
     ImportError: No module named NvidiaDetector.alternatives
    This file has 500 lines, many other warnings and erros in it. I believe that important is that i can't modprobe nvidia-current, there is no such module. I've managed to modprobe a module named nvidia. but after it drivers were't working too.

    4.nvidia-smi gives
    Code:
    NVIDIA: could not open the device file /dev/nvidiactl (No such device or address).
    After making such device with mknod and adding priveleges nothing changes.

    5.lspci -v gives (here's only graphic card):
    Code:
    01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 730M] (rev a1) (prog-if 00 [VGA controller])
     Subsystem: Acer Incorporated [ALI] Device 0648
     Flags: bus master, fast devsel, latency 0, IRQ 7
     Memory at b2000000 (32-bit, non-prefetchable) [size=16M]
     Memory at a0000000 (64-bit, prefetchable) [size=256M]
     Memory at b0000000 (64-bit, prefetchable) [size=32M]
     I/O ports at 2000 [disabled] [size=128]
     Expansion ROM at <ignored> [disabled]
     Capabilities: <access denied>
    (notice that there are no kernel drivers in use)

    6.blacklisted few things
    Code:
     blacklist amd76x_edac
     blacklist nouveau
     blacklist vga16fb
     blacklist rivafb
     blacklist nvidiafb
     blacklist rivatv
    Still no effect - I don't know which driver am i using now :/

    7.purged xserver-xorg-video-nouveau - no effect

    8. Tried to install nvidia driver (319.23) manually - installed succesfully, however before installation I've encountered a message saying that this driver couldn't find a chipset compatible with itself (driver's README says it is compatible, so does nvidia website).

    9. Did update-grub: there was a change in initail window (the one before logging screen). So I hoped something changed. Nope, still no modules nvidia or nvidia-current

    10.Installed bumblebee

    So, what else can I do? If there is no hope, which linux should i choose to work with CUDA (I mean, where installation of drivers is easy?).

    EDIT: this is what shows during dpkg-reconfigure nvidia-current:
    Code:
     File "/usr/share/apport/package-hooks/dkms_packages.py", line 22, in <module>
        import apport
    ImportError: No module named apport
    Error! Application of patch buildfix_kernel_3.8.patch failed.
    and
    Code:
    DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/lenovo_thinkpad
    DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/put_your_quirks_here
    DEBUG:Parsing /usr/share/ubuntu-drivers-common/quirks/dell_latitude
    DEBUG:Processing quirk ThinkPad T420s
    DEBUG:Failure to match V1.13 with ThinkPad T420s
    DEBUG:Quirk doesn't match
    DEBUG:Processing quirk Latitude E6530
    DEBUG:Failure to match Acer with Dell Inc.
    DEBUG:Quirk doesn't match
    Last edited by Ovy; June 23rd, 2013 at 09:17 PM.

Page 6 of 6 FirstFirst ... 456

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •