I'm writing this post from Mac OS X. After an update about 2 hours ago, my Ubuntu boots into a black, blank screen, when desktop is expected to display. I can see the logs like starting something, checking battery state before the screen turns black when quiet is off.
I got the same black screen when I tried to run Xorg failsafe mode.

Laptop details:
Memory: 8GB
Intel® Core™ i7-3615QM CPU @ 2.30GHz × 8
Graphics: GeForce GT 650M/PCIe/SSE2 + Intel HD 4000

Current system:
Ubuntu 12.10 (x64, with proposed update) with Linux 3.5.0-? (should be the newest version in xorg-edgers PPA), nomodeset, gfxmode line removed
Installed nvidia-current.
Booting from EFI
xorg-edgers PPA used.

The upgrade includes nvidia-current, and I suspect the latest NVIDIA driver is causing problems, but I'm not sure.

I tried to startx after login in a terminal, but it only outputs 2 lines and then it seems to be struck there.
I can confirm the system is fine expect display, for the laptop shuts down when I press the power button twice.

I also booted into recovery mode. Yes I get root shell, but when I try to turn on networking from the recovery menu, there is no more output after fsck message. It resumes to normal boot after I pressed ^C. And I don't know how to rmount / as read-write.

Maybe I could get the Xorg log file in the root shell, but how can I put it here? I mean, I don't even have access to the internet in recovery mode.

I can provide more information if needed. Please tell me if I forget about something.