I know, this is my third post in under an hour. However, my problem is evolving.

Before, I had posted about my sound not working and a red light in my headphone jack, and also my keyboard not working when I booted into Ubuntu. I'm dual booting Mountain LIon and Ubuntu 12.04 on a MacBook Pro 3,1.

Now, it's a lot worse. This time when I booted my keyboard was working fine. I logged in and all went well. I was testing my keyboard and everything worked fine. However, the sound controls on the keyboard (which had always worked fine before even though I had no sound) weren't doing anything. I went to the sound menu on the bar at the top of the screen. My sound slider was grayed out.

So I went to system settings > sound, and there were no options for output OR input devices, whereas before I had been able to see two output options and one input source.

I then went back to the main settings, temporarily delaying trying to fix that problem for the seemingly simple one of trying to fix a minor problem I'd been having all day - my title bars on windows still being Radiance title bars, after I had switched from Ambiance to Radiance and back to Ambiance again. I went into my appearance settings and selected Radiance again, thinking maybe if I switched to Radiance and back again it would solve the problem. But the moment I selected Radiance, I got an internal error. In more details it said something about a file path.

I then went back to system settings and went to network settings so that I could connect to my internet and post about the problem directly from Ubuntu, because network settings weren't showing up in the status bar at the top of the screen. When it went into network settings, I got another internal error at the same time as it said something like "network settings are not compatible with [blah blah blah]" (I could check if you need that text, I'm sure it's reproducible.

Major problems. I really need your help.