Firstly I am assuming you have done this:

Your other systems on the network must have their proxy settings set in the browser to point to the ip address of the dansguardian system and port 8080.

In Firefox 1.5:
Edit -> Preferences -> General -> Connection Settings -> Manual proxy configuration

In Firefox 2.0
Edit -> Preferences -> Advanced - Network Tab -> Settings -> Manual proxy configuration

Check manual proxy configuration and add “your DG box ip address” in first box and “8080” in second
Then tick “Use this proxy server for all protocols”

Secondly can you check that you have the entry in /etc/firehol/firehol.conf
that reads: server webcache accept