Just switched from Ubuntu to Xubuntu in order to ditch unity.

Loving how fast this is. All I have done since doing an entire clean install was updates, then installed the lastest nvidia driver from x-swat ppa (version 304.51 in nvidia x server settings). I also installed xubuntu-restricted-extras as well as any other programs I use.

Now, when trying to run a .mkv that is h.264 encoded with either smplayer, or mplayer from terminal, I get the same error no matter what I try.

Where did I go wrong?

Videos play fine using VX but take up about 50% of my core 2 duo.....

PHP Code:
christopher@G51VX-XUBUNTU:~/Videosmplayer -vo vdpau -vc ffh264vdpau test.mkv
MPlayer svn r34540 
(Ubuntu), built with gcc-4.6 (C2000-2012 MPlayer Team
could not connect to socket
No such file or directory
Failed to open LIRC support
You will not be able to use your remote control.

Playing test.mkv.
libavformat version 53.21.0 (external)
Mismatching header version 53.19.0
libavformat file format detected
matroska,webm 0x7f4e398b3940]Unknown entry 0x437E
[matroska,webm 0x7f4e398b3940]Unknown entry 0x437E
[matroska,webm 0x7f4e398b3940]Unknown entry 0x437E
[matroska,webm 0x7f4e398b3940]Unknown entry 0x437E
[matroska,webm 0x7f4e398b3940]Unknown entry 0x437E
[matroska,webm 0x7f4e398b3940]Unknown entry 0x437E
[matroska,webm 0x7f4e398b3940]max_analyze_duration reached
[matroska,webm 0x7f4e398b3940]Estimating duration from bitratethis may be inaccurate
[lavfstream 0video (h264), -vid 0
[lavfstream 1audio (aac), -aid 0
[lavfstream 2subtitle (***), -sid 0
:  [H264]  1280x720  0bpp  23.976 fps    0.0 kbps 0.0 kbyte/s)
Load subtitles in ./
Forced video codecffh264vdpau
Opening video decoder
: [ffmpegFFmpeg's libavcodec codec family
libavcodec version 53.35.0 (external)
Mismatching header version 53.32.2
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->192000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...

MPlayer interrupted by signal 11 in module: decode video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a '
gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn'
t happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version
. If you think it's MPlayer's faultplease read
/HTML/en/bugreports.html and follow the instructions thereWe can't and
t help unless you provide this information when reporting a possible bug.
This binary of MPlayer in Debian is currently compiled with
'--enable-debug'the debugging symbols are in the package