Results 1 to 2 of 2

Thread: Vsftpd problem

  1. #1
    Join Date
    Apr 2010
    Beans
    4

    Vsftpd problem

    Hi Guys!

    I'm currently setting up my ubuntu 10.04 server running on a vps to host a Drupal Site. Now I'm already on the development stage of my drupal site and I also need to update some modules which could be done through FTP.

    Now while searching over the web, I saw that to enable FTP on my ubuntu server, I have to install vsftpd. I installed it and I successfully transferred drupal core files, etc. using sftp in filezilla.

    Now my drupal site is reminding me to update some modules as well as the core files which could be done through ftp. So I obeyed the reminder and clicked to update it. Now it asks for my FTP server account username, password etc. and I entered all just like how I enter it using filezilla and *POOF* it denies me from logging in.

    Now I searched that there are settings on the vsftpd.conf file that should be changed to fix that issue and after it's changed, the vsftpd service should be restarted.

    So first I tried

    Code:
    sudo /etc/init.d/vsftpd restart
    and it resulted to "sudo: /etc/init.d/vsftpd: command not found"

    now I tried

    Code:
    service vsftpd restart
    and it resulted to "exec: 129: restart: not found".

    Now I tried to see what's wrong with /etc/init.d/vsftpd by

    Code:
    ls -l /etc/init.d
    and it results
    Code:
    .
    .
    .
    lrwxrwxrwx 1 root root    21 Oct  2 06:29 vsftpd -> /lib/init/upstart-job
    From here I now don't know what to do next to solve my problem.

    Any help would be greatly appreaciated!

    Thank You!

  2. #2
    Join Date
    May 2007
    Location
    San Francisco, California
    Beans
    5,849
    Distro
    Ubuntu

    Re: Vsftpd problem

    Try reimaging your VPS

    Code:
    dpkg --get-selections | grep php
    
    dpkg --get-selections | grep sql
    
    dpkg --get-selections | grep apache
    If any arise

    Code:
    apt purge package-name

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •