I've been using this older MBP 1,2 as a triple boot machine - OS 10.6.8, Meercat & XP in that boot order for several years now. Meercat always worked fine but not long ago I upgraded to 11.04 but was disappointed with long boot times. Everything did work tho so I then upgraded to 11.10 hoping for a better experience. No joy! Then I upgraded to 12.04 after reading all the positive reviews. Well I didn't get to explore it very much as it was quickly obvious that my wireless connection within Ubuntu would connect after entering my WPA key and then seconds later disconnect and ask me again to enter my WPA. I've searched the forums but it seems no one is using a MBP as old as mine. There are posts that refer to an area that lists compatible versions to various machines but I'll be damned if I can find it!

Bottom line - can this connection problem be fixed with 12.04 on my machine or should I go back to an older version like Meercat which worked great and was faster than the newer versions I tried. If it is the latter, how would I go about doing that? I already tried booting from the same disk I originally used to install Meercat but for some reason it just hangs at the first screen that gives all the options for as long as I'm willing to wait, which was almost an hour. Please help!