Results 1 to 2 of 2

Thread: Where is my /dev/ttyUSB*?

  1. #1
    Join Date
    Jul 2007

    Where is my /dev/ttyUSB*?

    There always was ttyUSB for linux.
    Now (12.04) I am connecting my usb device into usb port.
    I see dmesg
    usb 3-2: new full-speed USB device number 4 using uhci_hcd
    but how it transfer to my /dev/ttyUSB ?
    Last edited by marwooj; October 7th, 2012 at 02:40 PM.

  2. #2
    Join Date
    Feb 2013

    Re: Where is my /dev/ttyUSB*?

    I too did not find a /dev/ttyUSB*.
    This is what I did.
    I was installing an Arduino Replace Arduino with <YourDevice>

    Without Arduino plugged in
    $ lsusb

    With Arduino plugged in.
    $ lsusb

    I looked at the addition line.
    It Looked like this
    Bus 004 Device 003: ID 2341:0043
    I inserted the numbers in the command below.

    $ sudo modprobe usbserial vendor=0x2341 product=0x0043

    Without Arduino plugged in I:
    $ cd /dev
    $ ls
    With Arduino plugged in.
    $ ls
    I looked for the additional tty* NAME. I saw ttyAMC0, (yours may be ttyUSB* or ttyS*.)

    I did
    $ sudo minicom -s. but got "command not found" so I $ sudo apt-get install minicom then tried again.

    I changed the first line to /dev/ttyAMC0 (yours may be different.)

    I selected Save setup as dfl.
    Now my Arduino worked.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts