I'm assuming you've solved this by now, but I ran into the same problem recently and this was the best match in my search.

You probably have 5.1 audio enabled even though you only have stereo. Oddly enough all the help and troubleshooting documents skip checking this. The result is that the front left and front right audio (which is ambient noise usually) is the only audio you actually get out of your speakers. Switch it back to stereo and you should be good.

Open the "System Settings" program. Select "Sound" from the list. There should be a "Mode" drop-down you can select from. Select the audio you want, then click the "Test Sound" button and go through all the speakers to make sure you can hear something from all of them. If you can't, choose a different Mode.