Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: ubuntu installer doesn't detect hard disk

  1. #11
    Join Date
    Oct 2007

    Re: ubuntu installer doesn't detect hard disk

    Well, here is the actual output of fdisk:

    root@ubuntu:~# fdisk -l /dev/sda

    Disk /dev/sda: 160.0 GB, 160000000000 bytes
    255 heads, 63 sectors/track, 19452 cylinders, total 312500000 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0002e287

    Device Boot Start End Blocks Id System
    /dev/sda1 2048 8390655 4194304 82 Linux swap / Solaris
    /dev/sda2 8390656 159942655 75776000 83 Linux
    /dev/sda3 159942656 312498175 76277760 83 Linux

    As a last try, I resetted the MBR, but it didn't help...

  2. #12
    Join Date
    Oct 2007

    Re: ubuntu installer doesn't detect hard disk

    I tried to change the hard disk: same result.

    At the end, I tried with another distribution.
    First, I tried with ubuntu 12.10 beta: same result.
    Then I tried with opensuse and it installed without problems.

    First conclusion: I think there is a bug in the installer (ubiquity) which affects exactly my hardware configuration.

    Second conclusion: I have to quit ubuntu for something else.....

  3. #13
    Join Date
    Oct 2007

    Re: ubuntu installer doesn't detect hard disk

    I also tried ubuntu 11.10 and I got the same problem.

    In this very moment, I am writing while linux mint debian edition is installing correctly.

    Definetely, I think this problem is a bug of ubiquity.

    Where, and how, can I submit this bug?

  4. #14
    Join Date
    Nov 2009
    Mataro, Spain
    Ubuntu 14.04 Trusty Tahr

    Re: ubuntu installer doesn't detect hard disk

    Did any of you try to see if there is raid meta data present on the disk? If a disk has been used in fakeraid (biod raid) before, it keeps the meta data since most people only disconnect it and don't destroy the array properly. I'm not sure if it keeps the meta data if you destroy the array using the raid settings.

    Anyway, formatting doesn't help in this case, since the meta data is kept.

    What you can do from live mode to see if you are affected, is run this for disk /dev/sda (or change with /dev/sdX if the disk is called differently):
    sudo dmraid -E -r /dev/sda

    If it asks you if you want to remove meta data, this was the issue. Confirm and the installer will see the disk.
    If it has meta data it's ignored so that you don't install on existing raid array and destroy your data.

    PS. Also, if UEFI device is offered for boot, that means your board is UEFI capable, and you have to think carefully what you enable in BIOS since UEFI works in different way, especially if you plan to dual boot. There are still issues to be solved for UEFI dual boot.
    If you are happy with the old ways, just disable UEFI in BIOS if you have that option, and you're good to go. The setting for the sata mode should be AHCI, works much better than IDE.
    Ubuntu 14.04 LTS 64bit & Windows 10 Pro 64bit

  5. #15
    Join Date
    Oct 2007

    Re: ubuntu installer doesn't detect hard disk

    Darkod, you are just right!!!!!

    Thank you a lot.

    I already was suspecting that the disk was used in raid because the boy at the computer store said that it could let me try the "twin" of the previous hard disk...
    But knowing nothing about raid (but the definition) I didn't suspect it was relevant to this matter!

    Thanks again.

    About UEFI, I know it is still a somewhat a problem, but in my case I think I can ignore it: this computer is never going to see anything else than linux. May be it will be updated, sooner or later, but again with linux.


Page 2 of 2 FirstFirst 12


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts