Results 1 to 2 of 2

Thread: Can't install ubuntu

  1. #1
    Join Date
    Aug 2012

    Exclamation Can't install ubuntu

    I'm trying to do a standard install of Ubuntu 12.4.1 on my computer after accidentally using Pen Drive Linux's USB Installer on my Ubuntu partition. When trying to install i get an error saying unable to unmount /cdrom device busy.
    Upon checking Gparted i see that sda5 (what use to be SWAP space before my accident) is mounted to /cdrom and sda5 and 6(ubuntu partition) are both labeled PENDRIVE and sda5 indeed can't be unmounted.
    So i tried the command
    sudo umount -l -r -f /cdrom
    . No errors were given and upon checking Gparted is is indeed unmounted but i still can't format it to SWAP because the device is still "busy".
    Any suggestions?

  2. #2
    Join Date
    Jul 2010
    ozarks, Arkansas, USA
    Xubuntu 16.04 Xenial Xerus

    Re: Can't install ubuntu

    Champlin93; Hi ! Welcome to the forum .

    How about a approach like this:
    As a forced umount "umount -f" doesn't resolve anything . The quick fix is a lazy unmount:
    umount -l /mnt/deadmount
    Another fix for those who do not have mount -l option is smbumount (which worked like a charm for me), I did however first kill the smbmount process manually, not sure it that was needed. -> But:
    a better way is to learn which process uses the device
     umount /dev/sdb1
    <substitute your device/partition>
    umount: /dev/sdb1: device is busy <-output of command example
    umount: /dev/sdb1: device is busy <-output of command example
     fuser -m /dev/sdb1
    /dev/sdb1: 3322

    3322 is id of the process in this example that uses the device. if you like to know what it is, you may try this:
    ps aux | grep 3322
     kill -9 3322
     umount /dev/sdb1
    that should work..

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts