I bought a new PC, i5 cpu with built-in intel graphics.

I just plugged in my old harddisk from my old laptop with ubuntu 12.04 installed on it. I just plugged in the old harddisk and everything went well, except for the graphics, I guess. This is what is said in the Graphics section of the System Details:

Experience Fallback
The old laptop had an nvidia graphics card on it, and now my new hardware has a built-in Intel graphics.

When I try to run glxinfo, it gives me this error:
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig
I tried purging all Nvidia drivers by:
sudo apt-get purge nvidia*
which went well by the way, and re-installed xserver-xorg-video-intel, xserver-xorg-core, mesa-utils.

But when I try to reconfigure xserver by:
sudo dpkg-reconfigure xserver-xorg
nothing happens. it seems it's not being executed at all. I have tried executing it while "lightdm"is stopped, but still no result.
You have any idea why it's not working?

From one post in a forum, he experienced the same thing, and I was able to find out the following error from Xorg log by doing
less /var/log/Xorg.0.log | grep "gl"
and it gives me this:
[    30.432] (II) LoadModule: "glx"
[    30.432] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so
[    30.432] (EE) Failed to load /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so: libnvidia-tls.so.295.49: cannot open shared object file: No such file or directory
[    30.432] (II) UnloadModule: "glx"
[    30.432] (II) Unloading glx
[    30.432] (EE) Failed to load module "glx" (loader failed, 7)
Any ideas how to go about this?