Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: failed to fetch Firefox ppa

  1. #11
    Join Date
    Oct 2011
    Location
    London, UK
    Beans
    50
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: failed to fetch Firefox ppa

    This is the PPA for the aurora firefox builds.

    http://ppa.launchpad.net/ubuntu-mozi...-aurora/ubuntu

    I am currently having difficulty with it though. but only since the 21-9-2012

  2. #12
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: failed to fetch Firefox ppa

    Quote Originally Posted by Cavsfan View Post
    Thanks for that. I guess they stopped supporting Mozilla Firefox stable updates.
    The Ubuntu versions were deleted on September 25, 2012
    I did see that this exists:
    Code:
    http://ppa.launchpad.net/mozillateam/firefox-next/ubuntu/dists/lucid/
    It says:
    "This PPA will contain Milestone builds of the next version of Firefox (alpha, beta, RC)". This is for precise, oneiric, natty, maverick and lucid.

    Here is the page with the instructions on adding it:
    http://www.ubuntuupdates.org/ppa/mozilla_team_firefox_next?dist=lucid


    When I added that ppa and entered sudo apt-get update and sudo apt-get upgrade, the other error went away and I am being offered Firefox version 16!
    Pretty sweet.
    This should be the answer to your problem eival.
    I had to delete the firefox-stable ppa from /etc/apt/sources.list.d/.
    Quote Originally Posted by eival View Post
    so we cant get stable updates, only beta/prereleases?

    am i understanding that correctly?


    theres no way to just let Firefox standalone from the repos, and get its own updates from Mozilla?
    From what all I have seen this seems to be true. No Ubuntu version is listed in that ppa.
    The only other option is to remove the ppa and download the stable version from Mozilla.
    http://www.mozilla.org/en-US/firefox/fx/#desktop This is version 15.0.1 the most recent stable version.

    I am using version 16 right now and until I have a problem with it. I will use that stable ppa.
    The first time I have a problem I will do as I mentioned above.

    Unless someone knows more about where the stable firefox ppa went to.

  3. #13
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: failed to fetch Firefox ppa

    As you can see from this site in the warning in red:

    http://www.ubuntuupdates.org/ppa/mozilla_team_firefox_stable

    Check out this thread by lovinglinux Firefox +1 Mega Thread

    lovinglinux is a Firefox addon developer among other things.

  4. #14
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,722
    Distro
    Xubuntu

    Re: failed to fetch Firefox ppa

    15.0.1+build1-0ubuntu0.10.04.1 is available in the default repos last i checked
    sudo apt-get install firefox
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  5. #15
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: failed to fetch Firefox ppa

    Quote Originally Posted by pqwoerituytrueiwoq View Post
    15.0.1+build1-0ubuntu0.10.04.1 is available in the default repos last i checked
    sudo apt-get install firefox
    The only problem is that we installed this: ppa:mozillateam/firefox-stable many moons ago.

    And if you look at this you'll see this:
    WARNING: all packages have been deleted from this repository

  6. #16
    Join Date
    Jun 2008
    Beans
    434

    Re: failed to fetch Firefox ppa

    could this be because the 10.4 LTS cycle is coming to an end?

    this might be what finally forces me to upgrade to the 12 LTS

  7. #17
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: failed to fetch Firefox ppa

    How right you were pqwoerituytrueiwoq!
    Nice name BTW.

    All you have to do eival is:
    Enter this in terminal to get rid of that ppa:
    sudo ppa-purge ppa:mozillateam/firefox-stable
    Then answer "Y" to all of the prompts.

    I made a backup of my bookmarks in a json file but, then didn't need it.
    It's probably better to do that though.
    Then I purged firefox and whatever it took with it.
    sudo apt-get purge firefox
    Then sudo apt-get update && sudo apt-get install firefox and BAM I had Firefox version 15.0.1 installed.

    I guess the repositories caught up. I know you needed that ppa to obtain updates at one time.
    I haven't been in Lucid that much and didn't notice until now.
    But, the later versions of Ubuntu have the most up to date version of firefox in their repositories.

  8. #18
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: failed to fetch Firefox ppa

    Quote Originally Posted by eival View Post
    could this be because the 10.4 LTS cycle is coming to an end?

    this might be what finally forces me to upgrade to the 12 LTS
    No, see my previous post. The repositories were finally updated so that the most up to date version of Firefox is there now.

    I'm waiting until pretty close to April 2013 to get rid of Lucid. I believe it is the best Ubuntu I have used.

  9. #19
    Join Date
    Jun 2008
    Beans
    434

    Re: failed to fetch Firefox ppa

    okay i removed the PPA, but do i have to re-add one to continue getting updates for the stable 15.1+ when i check for updates using Update Manager or will they still come through?

    id rather avoid having to delete and reinstall while securing all my bookmarks/passwords/addons if i can bypass doing that.
    Last edited by eival; September 28th, 2012 at 10:55 PM.

  10. #20
    Join Date
    Aug 2009
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: failed to fetch Firefox ppa

    Quote Originally Posted by eival View Post
    okay i removed the PPA, but do i have to re-add one to continue getting updates for the stable 15.1+ when i check for updates using Update Manager or will they still come through?

    id rather avoid having to delete and reinstall while securing all my bookmarks/passwords/addons if i can bypass doing that.
    Yeah, you are good to go as you are.
    Both of our problems are resolved.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •