Results 1 to 10 of 10

Thread: take out word from spell check

  1. #1
    Join Date
    May 2006
    Location
    Lake Placid, Florida, USA
    Beans
    2,019
    Distro
    Xubuntu 14.04 Trusty Tahr

    take out word from spell check

    I'm trying to take the word "prof" from my LibreOffice spell check, I edited the .dic files , but the word still doesn't show as misspelled . I want this because I often misspell the word "proof" as prof and I want the spell check to show it as misspelled.
    perhaps there are more .dic files to edit?

  2. #2
    Join Date
    Aug 2011
    Location
    Cirencester, England
    Beans
    44
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: take out word from spell check

    I don't know how to remove a word from the dictionary. However, I do use AUTOCORRECT to correct my LibreOffice typing errors on the fly. For example I often type TEH rather than THE. When I actually wish to type TEH I just overide the suggested correction.

  3. #3
    Join Date
    May 2006
    Location
    Lake Placid, Florida, USA
    Beans
    2,019
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: take out word from spell check

    Problem is the spell check doesn't give me an option, it doesn't show "prof" as misspelled "proof" , because prof , I guess is a word .....
    So if I can take the word prof out of the spell check word list , then I thought it would show prof as misspelled proof.
    Hasn't anyone out there taken words out of the spell check list before ? if so please help me.

  4. #4
    rai4shu2 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: take out word from spell check

    If you have a system setup like mine, then it uses Hunspell for checking. In which case, you can edit the dictionary like this:

    Code:
    sudo leafpad /usr/share/hunspell/en_US.dic
    It appears to be plain text, so you just edit it. I think. I've never tried that, so please be careful.

  5. #5
    Join Date
    May 2006
    Location
    Lake Placid, Florida, USA
    Beans
    2,019
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: take out word from spell check

    rai4shu2 thanks for trying, but I tried that and I also edited the USR/share/dict files , but it still shows prof as a correct word.
    perhaps there is somewhere else I need to edit?

  6. #6
    Join Date
    May 2006
    Location
    Lake Placid, Florida, USA
    Beans
    2,019
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: take out word from spell check

    even my dictionary shows it as spelled right , so there must be another file I haven"t edited somewhere.

  7. #7
    rai4shu2 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: take out word from spell check

    Is your dictionary configured to go to localhost (or somewhere on the LAN)?

  8. #8
    Join Date
    May 2006
    Location
    Lake Placid, Florida, USA
    Beans
    2,019
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: take out word from spell check

    I think LibreOffice uses the aspell .dic file on this computer, I thought if I took the word off the list it would think it was misspelled , but perhaps I should have instead put some kind of flag on the word.
    I even tried making a personal .aspell.en.pws in my /home folder, but that didn't work.

  9. #9
    rai4shu2 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: take out word from spell check

    Maybe you should double-check LibreOffice's settings. Go to Tools / Options / Language Settings / Writing Aids and make sure that only the modules you want to use are selected.

  10. #10
    Join Date
    May 2006
    Location
    Lake Placid, Florida, USA
    Beans
    2,019
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: take out word from spell check

    Ok, I got it, I had to delete the word " prof " from the /usr/share/hunspell/en_US.dic file ( not the Aspell .dic ) .
    Now LibreOffice shows prof as misspelled like I wanted.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •