Results 1 to 4 of 4

Thread: Slow gvfs Samba Performance

Hybrid View

  1. #1
    Join Date
    Sep 2012
    Beans
    2

    Question Slow gvfs Samba Performance

    Hello,

    if I use/acces a Samba Share using Nautilus or manually using "gvfs-mount smb://SERVER-IP/Share" I get a poor Performance, only about 7 mb/s on my 100 Mbit Network.

    If I access the same Share on Windows I get Fullspeed 100 Mbit (About 11 mb/s), also if I mount using "sudo mount -t cifs //SERVER-IP/Share /mountpount" which uses cifs instead of gvfs I get fullspeed too, so can anyone tell me if there is a Performance Problem/Bug in gvfs or how gvfs is using SMB Shares differerently ?

    I tested read Perfomance (From my Network Samba Share) with multiples files and always, the cifs-Version is fullspeed and the GVFS-Version has some mb/s less.

    After some research I found some tips to optimize the Samba Settings of my Ubuntu Installation and some network tuning tips, but as the CIFS mounted share gets the full Network Speed I don't believe its that kind of problem.

  2. #2
    Join Date
    Sep 2012
    Beans
    2

    Re: Slow gvfs Samba Performance

    Can nobody reproduce the Problem or help me out in any way ?

  3. #3
    Join Date
    Apr 2007
    Beans
    116

    Re: Slow gvfs Samba Performance

    I'm afraid you are not the only one who has noticed this.

    I use smb4k to mount my shares as the gvfs-smb implementation is screwed.

    smb4k - 81mb/s, nautilus - gvfs - 31mb/s (rubbish)

    Quote Originally Posted by gnagfl0w View Post
    Can nobody reproduce the Problem or help me out in any way ?
    Last edited by db260179; September 30th, 2012 at 01:12 PM.

  4. #4
    Join Date
    Dec 2009
    Beans
    3

    Re: Slow gvfs Samba Performance

    The issue seems to be host resolution. Try hard-configuring the appropriate mappings in /etc/hosts.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •