Results 1 to 10 of 17

Thread: Can't work out how to run .jar file directly from USB music player in Ubuntu 12.04

Threaded View

  1. #11
    Join Date
    Aug 2011
    Xubuntu 14.04 Trusty Tahr

    Re: Can't work out how to run .jar file directly from USB music player in Ubuntu 12.

    OK, I downloaded and unzipped krut. I am using the Oracle java and you obviously are using OpenJDK. When I run krut through Oracle java I have no problem. It opens and runs fine. It doesn't matter whether I have the system set up to use Oracle java runtime to run jar files or manually run the java runtime with the -jar option. So, I am wondering if it doesn't have something to do with OpenJDK. Do you have this problem with any other jar files? I also assume that you are set up to automatically run a jar file with the OpenJDK runtime if you double click the jar file as it appears you are. 'Tiz a puzzlement. If you are not having a similar problem with other jar files and there is nothing odd about your installation of OpenJDK, you might kick the problem up to both the krut programmers and to the OpenJDK folks. Don't be surprised if they both don't say CND (cannot duplicate) but it might be worth a try.

    ADDED: I went back and tried to run KRUT.jar from the command line. With the x bit unset I got 'permission denied' as expected and then with sudo I got a 'command not found' as expected. Then, setting the x bit, I got 'invalid file (bad magic number): Exec format error' both normally and with sudo, again as expected.
    Last edited by agillator; September 28th, 2012 at 02:47 AM.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts