Results 1 to 7 of 7

Thread: VirtualBox Upgrade Failed

  1. #1
    Join Date
    Mar 2012
    Location
    /home/ubun2to
    Beans
    356
    Distro
    Ubuntu 13.04 Raring Ringtail

    VirtualBox Upgrade Failed

    I just downloaded the latest version of VirtualBox, and GDebi and the Software Center said that it could not open it because the package was corrupt or broken.
    So, I checked the checksums, and they were off, so I redownloaded it.
    Now, the Software Center says this:
    Code:
    Breaks existing package 'virtualbox-4.1' that conflict: 'virtualbox'. But the '/home/davidlucadou/Downloads/virtualbox-4.2_4.2.0-80737~Ubuntu~precise_amd64.deb' provides it via: 'virtualbox'
    GDebi gives me the same error.
    The Update Manager (retrieving packages from the official PPA) can't install it, either. This is the error I get:
    Code:
    davidlucadou@HP-DESKTOP:~$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be upgraded:
      virtualbox-4.1
    1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Need to get 70.1 MB of archives.
    After this operation, 420 kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://download.virtualbox.org/virtualbox/debian/ precise/contrib virtualbox-4.1 amd64 4.1.22-80657~Ubuntu~precise [70.1 MB]
    Fetched 70.1 MB in 3min 25s (342 kB/s)                                                                                               
    Preconfiguring packages ...
    (Reading database ... 423112 files and directories currently installed.)
    Preparing to replace virtualbox-4.1 4.1.18-78361~Ubuntu~precise (using .../virtualbox-4.1_4.1.22-80657~Ubuntu~precise_amd64.deb) ...
    dpkg: warning: subprocess old pre-removal script returned error exit status 1
    dpkg - trying script from the new package instead ...
    dpkg: error processing /var/cache/apt/archives/virtualbox-4.1_4.1.22-80657~Ubuntu~precise_amd64.deb (--unpack):
     subprocess new pre-removal script returned error exit status 1
    Processing triggers for python-central ...
    Errors were encountered while processing:
     /var/cache/apt/archives/virtualbox-4.1_4.1.22-80657~Ubuntu~precise_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    It asked me to close the VBoxSVC daemon, but it did not show up on the System Monitor, so it should have been closed.
    Why is this?
    Backups are amazing. 99% of data loss can be prevented by spending less than $100 on an external drive.
    If you have seen an error, there is a good chance someone else has, too. Google is your friend.

  2. #2
    Join Date
    Mar 2006
    Beans
    8,345

    Re: VirtualBox Upgrade Failed

    Try with

    Code:
    sudo dpkg --configure -a
    There is no greater religion than a truth.

  3. #3
    Join Date
    Jan 2013
    Beans
    1

    Re: VirtualBox Upgrade Failed

    Any news on that one?

    I have the exact same problem on Ubuntu 12.04 LTS (using the .deb package from virtualbox website):

    Breaks existing package 'virtualbox-4.1' that conflict: 'virtualbox'. But the '/***/Downloads/virtualbox-4.2_4.2.6-82870~Ubuntu~oneiric_i386.deb' provides it via: 'virtualbox'

    ("sudo apt-get upgrade" says everything is up to date - but this is unrelated)

    Thanks.
    Last edited by perlinpinpin; January 9th, 2013 at 06:24 PM.

  4. #4
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    3,267
    Distro
    Ubuntu 16.10 Yakkety Yak

    Re: VirtualBox Upgrade Failed

    Try removing virtualbox 4.1 first. I run 64-bit Ubuntu 12.04, but never did have virtualbox 4.1 because I first got into virtualbox when the current version was already 4.2.4 I think.

    So I originally followed the instructions on the virtualbox website for "Debian-based Linux distributions" to enable the repository for it when installing with apt-get, and it recently updated to 4.2.6 automatically.

    If you install a manually download a virtualbox deb file it will not update automatically if you did not add the proper repository and key.

    PS: Now that I reread the original post, maybe you need to temporarily comment out the virtualbox specific respository in sources.list to purge the old Ubuntu virtualbox.
    Last edited by efflandt; January 11th, 2013 at 06:01 AM.
    i5 650 3.2 GHz upgraded to i7 870, 16 GB 1333 RAM, nvidia GTX 1060, 32" 1080p & assorted older computers

  5. #5
    Join Date
    Dec 2013
    Beans
    1

    Re: VirtualBox Upgrade Failed

    look no more; the solution is here:
    http://ubuntuhandbook.org/index.php/...tu-linux-mint/
    nb

  6. #6
    Join Date
    Apr 2014
    Beans
    2

    Re: VirtualBox Upgrade Failed

    yo tengo el mismo problema, y al intentar repararlo aparece el siguiente error

    problemas de dependencias impiden la configuración de virtualbox-qt:
    virtualbox-qt depende de virtualbox (= 4.1.12-dfsg-2ubuntu0.6); sin embargo:
    La versión de `virtualbox' en el sistema es 4.1.12-dfsg-2ubuntu0.5.


    esto paso justo coando se actualizo la version de virtualbox y no encuentro manera de repararlo
    Last edited by sky-salim; April 29th, 2014 at 08:47 PM.

  7. #7
    Join Date
    Apr 2014
    Beans
    2

    Re: VirtualBox Upgrade Failed

    adicionalmente me manda este mensaje cuando trato de reinstalar

    El paquete virtualbox necesita ser reinstalado, pero no se encuentra un archivo para éste.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •