Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: Grub problem

  1. #1
    Join Date
    Sep 2012
    Beans
    33

    Grub problem

    After I installed mythbuntu 12.0.4.1 to a usb drive I was getting error out of disk and no suitable mode found. After showing these errors for a few minutes it would finish booting. I read that if I uncommented GRUB_TERMINAL=console in /etc/default/grub and ran sudo update-grub that should fix the error. Well now it won't boot to mythtv at all. It just boots to a grub prompt. From there I can do:
    set root=(hd0,1)
    linux /vmlinuz root=/dev/sda1 ro acpi=off noapic
    initrd /initrd.img
    boot
    and it boots up although I cannot select 1080p as a resolution when I believe it was running at that before. Also those commands seem very slow. It takes a minute or two before linux and initrd return.

    Here is my /etc/default/grub
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    # info -f grub -n 'Simple configuration'

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""

    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xe fefefef"

    # Uncomment to disable graphical terminal (grub-pc only)
    GRUB_TERMINAL=console

    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480

    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true

    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"

    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub problem

    You can try to repairs, but post the BootInfo link it creates:

    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
    https://help.ubuntu.com/community/Boot-Repair
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Sep 2012
    Beans
    33

    Re: Grub problem

    emedlin@mythtv:~$ sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
    Traceback (most recent call last):
    File "/usr/bin/add-apt-repository", line 125, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
    File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
    curl.perform()
    pycurl.error: (6, "Couldn't resolve host 'launchpad.net'")

    I am remoted into the machine through my lan, so I know the nic is working.

    emedlin@mythtv:/etc/network$ cat interfaces
    auto lo
    iface lo inet loopback
    auto eth0
    iface eth0 inet static
    address 192.168.10.100
    netmask 255.255.255.0
    gateway 192.168.10.1

    All though it looks like this machine cannot get out to the net for some reason.
    emedlin@mythtv:/etc/network$ telnet time-a.nist.gov 13 telnet: could not resolve time-a.nist.gov/13: Name or service not known

    Pretty sure this was working because it told me updates were available after I installed the OS.

  4. #4
    Join Date
    Sep 2012
    Beans
    33

    Re: Grub problem

    I can ping the router.
    emedlin@mythtv:/etc/network$ ping 192.168.10.1
    PING 192.168.10.1 (192.168.10.1) 56(84) bytes of data.
    64 bytes from 192.168.10.1: icmp_req=1 ttl=64 time=0.318 ms
    64 bytes from 192.168.10.1: icmp_req=2 ttl=64 time=0.302 ms
    64 bytes from 192.168.10.1: icmp_req=3 ttl=64 time=0.377 ms
    ^C
    --- 192.168.10.1 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 1999ms
    rtt min/avg/max/mdev = 0.302/0.332/0.377/0.035 ms

    I can ping my cable modem.
    emedlin@mythtv:/etc/network$ ping 192.168.100.1
    PING 192.168.100.1 (192.168.100.1) 56(84) bytes of data.
    64 bytes from 192.168.100.1: icmp_req=1 ttl=63 time=1.92 ms
    64 bytes from 192.168.100.1: icmp_req=2 ttl=63 time=1.90 ms
    64 bytes from 192.168.100.1: icmp_req=3 ttl=63 time=1.96 ms
    ^C
    --- 192.168.100.1 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2009ms
    rtt min/avg/max/mdev = 1.908/1.932/1.964/0.023 ms

    So, what could be blocking me?

  5. #5
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: Grub problem

    Your exact command works for me. But it checks my Ubuntu mirror and does updates also.

    Is you mirror working?
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  6. #6
    Join Date
    Sep 2012
    Beans
    33

    Re: Grub problem

    Not sure how do I test to see if my mirror is working?

  7. #7
    Join Date
    Sep 2012
    Beans
    33

    Re: Grub problem

    sudo apt-get update produces alot of Failed to fetch... lines.

    It seems the machine cannot get to the net, but can get to my cable modem and other machine on my network. What would cause this?

  8. #8
    Join Date
    Jan 2008
    Location
    France
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Grub problem

    Hi
    You should create another thread in order to get help for this network problem. Once it is solved, come back here so that we can check your GRUB problem.

  9. #9
    Join Date
    Sep 2012
    Beans
    33

    Re: Grub problem

    http://paste.ubuntu.com/1215882/

    This is what I got after clicking Recommended Repair.

  10. #10
    Join Date
    Sep 2012
    Beans
    33

    Re: Grub problem

    I rebooted it and it is setting with a black screen with a blinking cursor in the upper left hand corner.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •