Page 7 of 7 FirstFirst ... 567
Results 61 to 66 of 66

Thread: iOS 6 doesn't recognize CUPS print shares

  1. #61
    Join Date
    Sep 2012
    Beans
    2

    Re: iOS 6 doesn't recognize CUPS print shares

    Hi All,

    When choosing one copy of a PDF job, the device sends a PDF. But when choosing 2 copies, the print job is URF format.
    Is there any way to disable this URF, to always receive PDF print jobs?

    Thanks,
    Oliver

  2. #62
    Join Date
    Sep 2009
    Beans
    46

    Re: iOS 6 doesn't recognize CUPS print shares

    Quote Originally Posted by Sven Verhaegen View Post
    can someone make sure this is included in the 12.04 CUPS ?
    Running iOS 6 on my iPad3. This technique works perfectly with 10.04 (Lucid). Thanks.

    One problem though. If/when the WiFi connection drops and then reconnects, the iPad can't find the printer and I have to restart cups in order to print again. Anyone else run into this issue.

    I saw a link to this discussion earlier in the thread

    http://forums.macrumors.com/showthread.php?t=1396875

    but that seems to indicate that enabling/disabling WiFi solves the problem, but that isn't true in my case. Restarting cups seems to be my only solution right now and that isn't ideal.

  3. #63
    Join Date
    Nov 2012
    Beans
    1

    Re: iOS 6 doesn't recognize CUPS print shares

    I ran airprint-generate on my Ubuntu 12.04 64-bit machine. That, along with the cups config files from James Elliot in Post #43 nearly had everything working for iPhone 4 with either iOS 5.0.1 or iOS 6.0.1. I did have to change the avahi .service files generated as follows

    Code:
                                                                                       -  <txt-record>URF=none</txt-record>
    +  <txt-record>URF=DM3</txt-record>
    once I did that, airprint works from both iOS 5 and 6. (iPhone 4). Haven't tested other iStuff.

    That all was kind of a pain, so I put it all together in a fork of tjfontaine's airprint-generate. It includes the appropriate fix in the python script. The github repo also includes the cups files. I have a pull request in with the main airprint-generate repo. Until that time, you can get code with these latest commits at:

    https://github.com/cainscou/airprint-generate

    hope this is useful to someone.

  4. #64
    Join Date
    Sep 2012
    Beans
    16

    Re: iOS 6 doesn't recognize CUPS print shares

    New CUPS version is released (for 12.04)


    An update to cups-bsd from 1.5.3-0ubuntu5.1 to 1.5.3-0ubuntu6 is available.
    An update to cups-client from 1.5.3-0ubuntu5.1 to 1.5.3-0ubuntu6 is available.
    An update to cups-common from 1.5.3-0ubuntu5.1 to 1.5.3-0ubuntu6 is available.
    An update to cups-ppdc from 1.5.3-0ubuntu5.1 to 1.5.3-0ubuntu6 is available.


    The printers are by default exported and working without the work-around ...... just tested it
    You off-course need to have DNSSD enabled on CUPS otherwise the printers are not shown up [ sudo cupsctl 'BrowseLocalProtocols="cups dnssd"' ]

    I now have the printers twice, will see if the "rollback" is simply deleting the 2 mime files and the avahi service files (i guess that should be it, nothing more or less)

  5. #65
    Join Date
    Feb 2013
    Beans
    2

    Re: iOS 6 doesn't recognize CUPS print shares

    Hello all - for the record I've found that although using a TXT record of 'URF=none' can work OK for printing from most applications (mail, pages, safari), I couldn't get anything to print from iBooks or keynote. With 'URF=DM3' they seem to work too. Hooray!

    Incidentally, while multicast DNS-SD is really cool to have in cups, I personally created the relevant SRV and TXT records in the name server of my WLAN subnet - this is a bit more useful if your print server, like mine, is on a different (wired) subnet. I got the idea from http://www.dns-sd.org/ServerSetup.html

    Many thanks for sharing all the so-useful information.
    Martin

  6. #66
    Join Date
    Nov 2005
    Location
    New York, USA
    Beans
    1,223
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: iOS 6 doesn't recognize CUPS print shares

    I just had a similar problem. My wife has an iPad 3 and she wanted to print to a shared printer on our network that is hanging off a 64 bit Ubuntu 12.04 server. I found the following info that worked with minimal fuss. No config files to mess with, just some simple point and click GUI stuff (other then running one command in terminal, and if I just logged off and on after adding the startup application info, that would not have been necessary).

    The author says this fix was broken by iOS 6, but with a current 64 bit version of 12.04.2 and iOS 6.1.3 it works perfectly from an iPad.

    The following is exactly what I found....

    https://plus.google.com/101074687909...ts/jRfoeKfwHxM
    Keith Weinberg

    Shared publicly - May 28, 2012
    Airprint from all your existing Linux printers. (for free obviously -- no need to buy a new printer to print from an Ipad)


    The solution for precise (ubuntu 12.04)
    1) Download the latest deb from http://ppa.launchpad.net/hughescih/p...rprint-daemon/
    2) find the file and double-click, choose "Install"
    3) open Printers and, in the "top bar", choose Server Settings
    4) follow instruction and image at:
    http://www.azsoftwaredownload.com/li...support-ubuntu

    It worked for me. . . printing from the ipad on an old (but still good) printer.
    Index of /hughescih/ppa/ubuntu/pool/main/a/airprint-daemon
    ppa.launchpad.net




    Here is what I did...

    Fairly simple. I down loaded the deb, clicked to install it.
    I opened a terminal and ran the command...
    airprint-daemon


    Then I closed the terminal. Nothing showed up in running processes.
    Open the printer settings. In top panel click on Server and make sure the boxes to share the printer and print from internet are checked.


    Close the dialog.


    To make it permanent, I added to the startup applications,


    Airport-Daemon
    /usr/sbin/airprint-daemon
    Airprint support for iOS devices


    All my printers showed up in the ipad right away. It would not print until I selected to turn off 2 sided printing on the iPad print dialog.
    Using Ubuntu since Warty Warthog (4.10)
    32 bit 5.04>5.10>6.06>6.10>7.04>7.10>8.04>8.10>9.04>9.10
    64 bit 9.10 upgraded to 10.04>10.10>11.04>11.10>12.04>14.04

Page 7 of 7 FirstFirst ... 567

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •