Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Cannot Repair Package Catalog

  1. #1
    Join Date
    Sep 2011
    Beans
    20

    Cannot Repair Package Catalog

    Ubuntu 12.04
    Asus - U43F

    "Items cannot be installed...until package catalog is repaired"

    Ok...clicking repair fails. Here is the error:
    Code:
     installArchives() failed: dpkg: error processing libk5crypto3 (--configure): 
     libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3:i386 is in a different version (1.10+dfsg~beta1-2ubuntu0.1) 
    dpkg: error processing libk5crypto3:i386 (--configure): 
     libk5crypto3:i386 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libk5crypto3:amd64 is in a different version (1.10+dfsg~beta1-2ubuntu0.3) 
    dpkg: dependency problems prevent configuration of libkrb5-3: 
     libkrb5-3 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however: 
      Package libk5crypto3 is not configured yet. 
    dpkg: error processing libkrb5-3 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2: 
     libgssapi-krb5-2 depends on libk5crypto3 (>= 1.8+dfsg); however: 
      Package libk5crypto3 is not configured yet. 
     libgssapi-krb5-2 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however: 
      Package libkrb5-3 is not configured yet. 
    dpkg: error processing libgssapi-krb5-2 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libgssrpc4: 
     libgssrpc4 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however: 
      Package libgssapi-krb5-2 is not configured yet. 
    dpkg: error processing libgssrpc4 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkadm5srv-mit8No apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because the error message indicates its a followup error from a previous failure.
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
    : 
     libkadm5srv-mit8 depends on libgssapi-krb5-2 (>= 1.6.dfsg.2); however: 
      Package libgssapi-krb5-2 is not configured yet. 
     libkadm5srv-mit8 depends on libgssrpc4 (>= 1.6.dfsg.2); however: 
      Package libgssrpc4 is not configured yet. 
     libkadm5srv-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however: 
      Package libk5crypto3 is not configured yet. 
     libkadm5srv-mit8 depends on libkrb5-3 (>= 1.9+dfsg~beta1); however: 
      Package libkrb5-3 is not configured yet. 
    dpkg: error processing libkadm5srv-mit8 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkadm5clnt-mit8: 
     libkadm5clnt-mit8 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however: 
      Package libgssapi-krb5-2 is not configured yet. 
     libkadm5clnt-mit8 depends on libgssrpc4 (>= 1.6.dfsg.2); however: 
      Package libgssrpc4 is not configured yet. 
     libkadm5clnt-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however: 
      Package libk5crypto3 is not configured yet. 
     libkadm5clnt-mit8 depends on libkrb5-3 (>= 1.8+dfsg); however: 
      Package libkrb5-3 is not configured yet. 
    dpkg: error processing libkadm5clnt-mit8 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of krb5-multidev: 
     krb5-multidev depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libkrb5-3 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libk5crypto3 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libgssapi-krb5-2 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libgssrpc4 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libkadm5srv-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libkadm5clnt-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
    dpkg: error processing krb5-multidev (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkrb5-dev: 
     libkrb5-dev depends on krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Package krb5-multidev is not configured yet. 
    dpkg: error processing libkrb5-dev (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkrb5-3:i386: 
     libkrb5-3:i386 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however: 
      Package libk5crypto3:i386 is not configured yet. 
    dpkg: error processing libkrb5-3:i386 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2:i386: 
     libgssapi-krb5-2:i386 depends on libk5crypto3 (>= 1.8+dfsg); however: 
      Package libk5crypto3:i386 is not configured yet. 
     libgssapi-krb5-2:i386 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however: 
      Package libkrb5-3:i386 is not configured yet. 
    dpkg: error processing libgssapi-krb5-2:i386 (--configure): 
     dependency problems - leaving unconfigured 
    Errors were encountered while processing: 
     libk5crypto3 
     libk5crypto3:i386 
     libkrb5-3 
     libgssapi-krb5-2 
     libgssrpc4 
     libkadm5srv-mit8 
     libkadm5clnt-mit8 
    dpkg: dependency problems prevent configuration of krb5-multidev: 
     krb5-multidev depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libkrb5-3 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libk5crypto3 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libgssapi-krb5-2 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libgssrpc4 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libkadm5srv-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
     krb5-multidev depends on libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of libkadm5clnt-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3. 
    dpkg: error processing krb5-multidev (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: error processing libk5crypto3 (--configure): 
     libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3:i386 is in a different version (1.10+dfsg~beta1-2ubuntu0.1) 
    dpkg: error processing libk5crypto3:i386 (--configure): 
     libk5crypto3:i386 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libk5crypto3:amd64 is in a different version (1.10+dfsg~beta1-2ubuntu0.3) 
    dpkg: dependency problems prevent configuration of libkadm5srv-mit8: 
     libkadm5srv-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however: 
      Package libk5crypto3 is not configured yet. 
    dpkg: error processing libkadm5srv-mit8 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkadm5clnt-mit8: 
     libkadm5clnt-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however: 
      Package libk5crypto3 is not configured yet. 
    dpkg: error processing libkadm5clnt-mit8 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkrb5-dev: 
     libkrb5-dev depends on krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Package krb5-multidev is not configured yet. 
    dpkg: error processing libkrb5-dev (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkrb5-3: 
     libkrb5-3 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however: 
      Package libk5crypto3 is not configured yet. 
    dpkg: error processing libkrb5-3 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libkrb5-3:i386: 
     libkrb5-3:i386 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however: 
      Package libk5crypto3:i386 is not configured yet. 
    dpkg: error processing libkrb5-3:i386 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2: 
     libgssapi-krb5-2 depends on libk5crypto3 (>= 1.8+dfsg); however: 
      Package libk5crypto3 is not configured yet. 
     libgssapi-krb5-2 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however: 
      Package libkrb5-3 is not configured yet. 
    dpkg: error processing libgssapi-krb5-2 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2:i386: 
     libgssapi-krb5-2:i386 depends on libk5crypto3 (>= 1.8+dfsg); however: 
      Package libk5crypto3:i386 is not configured yet. 
     libgssapi-krb5-2:i386 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however: 
      Package libkrb5-3:i386 is not configured yet. 
    dpkg: error processing libgssapi-krb5-2:i386 (--configure): 
     dependency problems - leaving unconfigured 
    dpkg: dependency problems prevent configuration of libgssrpc4: 
     libgssrpc4 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however: 
      Package libgssapi-krb5-2 is not configured yet. 
    dpkg: error processing libgssrpc4 (--configure): 
     dependency problems - leaving unconfigured
    I have tried to run
    Code:
     sudo apt-get  -f install
    This produces another error. Here is the result:

    Code:
     Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      libunity6 libqapt-runtime libboost-program-options1.46.1
      akonadi-backend-mysql libqapt1 shared-desktop-ontologies libntrack0
      ntrack-module-libnl-0 libntrack-qt4-1
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      krb5-multidev libk5crypto3:i386 libkrb5-dev
    Suggested packages:
      krb5-doc krb5-doc:i386 krb5-user:i386
    The following packages will be upgraded:
      krb5-multidev libk5crypto3:i386 libkrb5-dev
    3 upgraded, 0 newly installed, 0 to remove and 302 not upgraded.
    11 not fully installed or removed.
    Need to get 213 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Get:1 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libkrb5-dev amd64 1.10+dfsg~beta1-2ubuntu0.3 [11.0 kB]
    Get:2 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main krb5-multidev amd64 1.10+dfsg~beta1-2ubuntu0.3 [125 kB]
    Get:3 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libk5crypto3 i386 1.10+dfsg~beta1-2ubuntu0.3 [77.4 kB]
    Fetched 213 kB in 0s (387 kB/s)      
    dpkg: error processing libk5crypto3 (--configure):
     libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3:i386 is in a different version (1.10+dfsg~beta1-2ubuntu0.1)
    dpkg: error processing libk5crypto3:i386 (--configure):
     libk5crypto3:i386 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libk5crypto3:amd64 is in a different version (1.10+dfsg~beta1-2ubuntu0.3)
    dpkg: dependency problems prevent configuration of libkrb5-3:
     libkrb5-3 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however:
      Package libk5crypto3 is not configured yet.
    dpkg: error processing libkrb5-3 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2:
     libgssapi-krb5-2 depends on libk5crypto3 (>= 1.8+dfsg); however:
      Package libk5crypto3 is not configured yet.
     libgssapi-krb5-2 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
      Package libkrb5-3 is not configured yet.
    dpkg: error processing libgssapi-krb5-2 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgssrpc4:
     libgssrpc4 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however:
      Package libgssapi-krb5-2 is not configured yet.
    dpkg: error processing libgssrpc4 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkadm5srv-mit8No apport report written because the error message indicates its a followup error from a previous failure.
                 No apport report written because the error message indicates its a followup error from a previous failure.
                                           No apport report written because MaxReports is reached already
                         No apport report written because MaxReports is reached already
       No apport report written because MaxReports is reached already
                                                                     No apport report written because MaxReports is reached already
                                                   No apport report written because MaxReports is reached already
                                 :
     libkadm5srv-mit8 depends on libgssapi-krb5-2 (>= 1.6.dfsg.2); however:
      Package libgssapi-krb5-2 is not configured yet.
     libkadm5srv-mit8 depends on libgssrpc4 (>= 1.6.dfsg.2); however:
      Package libgssrpc4 is not configured yet.
     libkadm5srv-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is not configured yet.
     libkadm5srv-mit8 depends on libkrb5-3 (>= 1.9+dfsg~beta1); however:
      Package libkrb5-3 is not configured yet.
    dpkg: error processing libkadm5srv-mit8 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkadm5clnt-mit8:
     libkadm5clnt-mit8 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however:
      Package libgssapi-krb5-2 is not configured yet.
     libkadm5clnt-mit8 depends on libgssrpc4 (>= 1.6.dfsg.2); however:
      Package libgssrpc4 is not configured yet.
     libkadm5clnt-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is not configured yet.
     libkadm5clnt-mit8 depends on libkrb5-3 (>= 1.8+dfsg); however:
      Package libkrb5-3 is not configured yet.
    dpkg: error processing libkadm5clnt-mit8 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of krb5-multidev:
     krb5-multidev depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libkrb5-3 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libk5crypto3 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libgssapi-krb5-2 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libgssrpc4 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libkadm5srv-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libkadm5clnt-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3.
    dpkg: error processing krb5-multidev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkrb5-dev:
     libkrb5-dev depends on krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Package krb5-multidev is not configured yet.
    dpkg: error processing libkrb5-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkrb5-3:i386:
     libkrb5-3:i386 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however:
      Package libk5crypto3:i386 is not configured yet.
    dpkg: error processing libkrb5-3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2:i386:
     libgssapi-krb5-2:i386 depends on libk5crypto3 (>= 1.8+dfsg); however:
      Package libk5crypto3:i386 is not configured yet.
     libgssapi-krb5-2:i386 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
      Package libkrb5-3:i386 is not configured yet.
    dpkg: error processing libgssapi-krb5-2:i386 (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     libk5crypto3
     libk5crypto3:i386
     libkrb5-3
     libgssapi-krb5-2
     libgssrpc4
     libkadm5srv-mit8
     libkadm5clnt-mit8
     krb5-multidev
     libkrb5-dev
     libkrb5-3:i386
     libgssapi-krb5-2:i386
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Don't know what the hell to do with this. I understand that libk4crypto3 is a package for Kerberos. Do I just remove the packages?

    Thanks for any help

  2. #2
    Join Date
    Jul 2012
    Location
    /home/
    Beans
    196
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: Cannot Repair Package Catalog

    Try if this helps:
    Code:
    sudo dpkg --configure -a

  3. #3
    Join Date
    Sep 2011
    Beans
    20

    Re: Cannot Repair Package Catalog

    This was the result of the command:

    sudo dpkg --configure -a

    Code:
     dpkg: dependency problems prevent configuration of krb5-multidev:
     krb5-multidev depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libkrb5-3 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libk5crypto3 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libk5crypto3 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libgssapi-krb5-2 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libgssapi-krb5-2 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libgssrpc4 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libgssrpc4 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libkadm5srv-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libkadm5srv-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3.
     krb5-multidev depends on libkadm5clnt-mit8 (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Version of libkadm5clnt-mit8 on system is 1.10+dfsg~beta1-2ubuntu0.3.
    dpkg: error processing krb5-multidev (--configure):
     dependency problems - leaving unconfigured
    dpkg: error processing libk5crypto3 (--configure):
     libk5crypto3:amd64 1.10+dfsg~beta1-2ubuntu0.3 cannot be configured because libk5crypto3:i386 is in a different version (1.10+dfsg~beta1-2ubuntu0.1)
    dpkg: error processing libk5crypto3:i386 (--configure):
     libk5crypto3:i386 1.10+dfsg~beta1-2ubuntu0.1 cannot be configured because libk5crypto3:amd64 is in a different version (1.10+dfsg~beta1-2ubuntu0.3)
    dpkg: dependency problems prevent configuration of libkadm5srv-mit8:
     libkadm5srv-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is not configured yet.
    dpkg: error processing libkadm5srv-mit8 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkadm5clnt-mit8:
     libkadm5clnt-mit8 depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is not configured yet.
    dpkg: error processing libkadm5clnt-mit8 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkrb5-dev:
     libkrb5-dev depends on krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2); however:
      Package krb5-multidev is not configured yet.
    dpkg: error processing libkrb5-dev (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkrb5-3:
     libkrb5-3 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however:
      Package libk5crypto3 is not configured yet.
    dpkg: error processing libkrb5-3 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkrb5-3:i386:
     libkrb5-3:i386 depends on libk5crypto3 (>= 1.9+dfsg~beta1); however:
      Package libk5crypto3:i386 is not configured yet.
    dpkg: error processing libkrb5-3:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2:
     libgssapi-krb5-2 depends on libk5crypto3 (>= 1.8+dfsg); however:
      Package libk5crypto3 is not configured yet.
     libgssapi-krb5-2 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
      Package libkrb5-3 is not configured yet.
    dpkg: error processing libgssapi-krb5-2 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgssapi-krb5-2:i386:
     libgssapi-krb5-2:i386 depends on libk5crypto3 (>= 1.8+dfsg); however:
      Package libk5crypto3:i386 is not configured yet.
     libgssapi-krb5-2:i386 depends on libkrb5-3 (= 1.10+dfsg~beta1-2ubuntu0.3); however:
      Package libkrb5-3:i386 is not configured yet.
    dpkg: error processing libgssapi-krb5-2:i386 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libgssrpc4:
     libgssrpc4 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however:
      Package libgssapi-krb5-2 is not configured yet.
    dpkg: error processing libgssrpc4 (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     krb5-multidev
     libk5crypto3
     libk5crypto3:i386
     libkadm5srv-mit8
     libkadm5clnt-mit8
     libkrb5-dev
     libkrb5-3
     libkrb5-3:i386
     libgssapi-krb5-2
     libgssapi-krb5-2:i386
     libgssrpc4

  4. #4
    Join Date
    Sep 2011
    Beans
    20

    Re: Cannot Repair Package Catalog

    Shamelessly bumping this thread.

  5. #5
    Join Date
    Nov 2008
    Beans
    Hidden!

    Re: Cannot Repair Package Catalog

    Shamelessly answering bump thread

    Give this a try:

    sudo apt-get clean

    sudo apt-get update

  6. #6
    Join Date
    Sep 2012
    Location
    Virginia, USA
    Beans
    209
    Distro
    Ubuntu Development Release

    Re: Cannot Repair Package Catalog

    If it still doesn't work after trying what jerrrys said, try these commands (yep, all of them, some of which you've already tried, but let'st just be thorough):

    Code:
    sudo apt-get autoremove
    sudo apt-get autoclean
    sudo apt-get clean
    sudo apt-get update
    sudo dpkg --configure -a
    sudo apt-get install -f
    sudo apt-get dist-upgrade
    If that still doesn't work, try:

    Code:
    sudo apt-get purge libk5crypto3 libk5crypto3:i386 libkrb5-3 libgssapi-krb5-2 libgssrpc4 libkadm5srv-mit8 libkadm5clnt-mit8 krb5-multidev libkrb5-dev libkrb5-3:i386 libgssapi-krb5-2:i386
    sudo apt-get clean
    sudo apt-get update
    sudo apt-get dist-upgrade
    If that didn't work, my question is: have you been installing packages from other sources without using apt-get? If so (or if you're just not sure), try this command:

    Code:
    sudo dpkg --remove --force-remove-reinstreq libk5crypto3 libk5crypto3:i386 libkrb5-3 libgssapi-krb5-2 libgssrpc4  libkadm5srv-mit8 libkadm5clnt-mit8 krb5-multidev libkrb5-dev  libkrb5-3:i386 libgssapi-krb5-2:i386
    and then
    Code:
    sudo apt-get update && sudo apt-get dist-upgrade
    If you're still having issues at this point, post again to say so.
    Asus K55A (Core i5-3210M @ 2.5GHz/8GB RAM/120GB SSD/Intel HD 4000) with Ubuntu 12.10 Beta 2
    Compaq Presario C700 (Pentium Dual-Core @ 1.6GHz/2.5GB RAM/500GB HDD/Intel GM965) with Arch Linux and Linux Mint Debian Edition

  7. #7
    Join Date
    Sep 2011
    Beans
    20

    Re: Cannot Repair Package Catalog

    Hey thanks y'all.

    Here is the result of the command:
    Code:
    sudo dpkg --remove --force-remove-reinstreq libk5crypto3 libk5crypto3:i386 libkrb5-3 libgssapi-krb5-2 libgssrpc4  libkadm5srv-mit8 libkadm5clnt-mit8 krb5-multidev libkrb5-dev  libkrb5-3:i386 libgssapi-krb5-2:i386
    Code:
    dpkg: dependency problems prevent removal of libk5crypto3:
     libkdb5-6 depends on libk5crypto3 (>= 1.7+dfsg); however:
      Package libk5crypto3 is to be removed.
     samba-common-bin depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is to be removed.
     smbclient depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is to be removed.
     libsmbclient depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is to be removed.
     winbind depends on libk5crypto3 (>= 1.6.dfsg.2); however:
      Package libk5crypto3 is to be removed.
    dpkg: error processing libk5crypto3 (--remove):
     dependency problems - not removing
    (Reading database ... 350037 files and directories currently installed.)
    Removing libk5crypto3:i386 ...
    dpkg: dependency problems prevent removal of libkrb5-3:
     cups depends on libkrb5-3 (>= 1.6.dfsg.2); however:
      Package libkrb5-3 is to be removed.
     libkdb5-6 depends on libkrb5-3 (>= 1.7dfsg); however:
      Package libkrb5-3 is to be removed.
     samba-common-bin depends on libkrb5-3 (>= 1.10+dfsg~); however:
      Package libkrb5-3 is to be removed.
     evolution-exchange depends on libkrb5-3 (>= 1.6.dfsg.2).
     smbclient depends on libkrb5-3 (>= 1.10+dfsg~); however:
      Package libkrb5-3 is to be removed.
     libsmbclient depends on libkrb5-3 (>= 1.10+dfsg~); however:
      Package libkrb5-3 is to be removed.
     winbind depends on libkrb5-3 (>= 1.10+dfsg~); however:
      Package libkrb5-3 is to be removed.
     dnsutils depends on libkrb5-3 (>= 1.6.dfsg.2).
    dpkg: error processing libkrb5-3 (--remove):
     dependency problems - not removing
    dpkg: dependency problems prevent removal of libgssapi-krb5-2:
     cups depends on libgssapi-krb5-2 (>= 1.8+dfsg).
     libdns81 depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     openssh-client depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     libcamel-1.2-29 depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     samba-common-bin depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     libgnomevfs2-extra depends on libgssapi-krb5-2 (>= 1.7+dfsg).
     libcurl3 depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     smbclient depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     libcups2 depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     libsmbclient depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     libneon27-gnutls depends on libgssapi-krb5-2 (>= 1.7+dfsg).
     libcurl3-nss depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     winbind depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
     libcurl3-gnutls depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
    dpkg: error processing libgssapi-krb5-2 (--remove):
     dependency problems - not removing
    dpkg: dependency problems prevent removal of libgssrpc4:
     libkdb5-6 depends on libgssrpc4 (>= 1.7dfsg~alpha1).
    dpkg: error processing libgssrpc4 (--remove):
     dependency problems - not removing
    Removing libkadm5srv-mit8 ...
    Removing libkadm5clnt-mit8 ...
    Removing krb5-multidev ...
    dpkg: dependency problems prevent removal of libkrb5-dev:
     libcups2-dev depends on libkrb5-dev.
    dpkg: error processing libkrb5-dev (--remove):
     dependency problems - not removing
    Removing libkrb5-3:i386 ...
    dpkg: dependency problems prevent removal of libgssapi-krb5-2:i386:
     libcups2:i386 depends on libgssapi-krb5-2 (>= 1.10+dfsg~).
    dpkg: error processing libgssapi-krb5-2:i386 (--remove):
     dependency problems - not removing
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    Errors were encountered while processing:
     libk5crypto3
     libkrb5-3
     libgssapi-krb5-2
     libgssrpc4
     libkrb5-dev
     libgssapi-krb5-2:i386
    I tried all the commands. Tried to remove the packages and then did 'apt-get update'.
    The software center still had errors. Attempts to fix it gave this result:

    Code:
    installArchives() failed: dpkg: dependency problems prevent configuration of libkrb5-dev: 
     libkrb5-dev depends on krb5-multidev (= 1.10+dfsg~beta1-2ubuntu0.2); however: 
      Version of krb5-multidev on system is 1.10+dfsg~beta1-2ubuntu0.3. 
    dpkg: error processing libkrb5-dev (--configure): 
     dependency problems - leaving unconfigured 
    No apport report written because the error message indicates its a followup error from a previous failure.
    Errors were encountered while processing: 
     libkrb5-dev

  8. #8
    Join Date
    Sep 2012
    Location
    Virginia, USA
    Beans
    209
    Distro
    Ubuntu Development Release

    Re: Cannot Repair Package Catalog

    Can you please post the contents of /etc/apt/sources.list here? Also, are you using any PPAs? Finally, can you say a bit about what you were doing prior to encountering this message? For example, have you manually installed .deb packages from non-Ubuntu sources, or that sort of thing? (I ask because, in some of the error messages, it is saying that you have packages on your system that are newer than those in the repos.)
    Asus K55A (Core i5-3210M @ 2.5GHz/8GB RAM/120GB SSD/Intel HD 4000) with Ubuntu 12.10 Beta 2
    Compaq Presario C700 (Pentium Dual-Core @ 1.6GHz/2.5GB RAM/500GB HDD/Intel GM965) with Arch Linux and Linux Mint Debian Edition

  9. #9
    Join Date
    Sep 2011
    Beans
    20

    Re: Cannot Repair Package Catalog

    I usually dont try to install anything without the software center, since I don't know how to fully use Ubuntu linux and wouldn't want to **** it up. I was trying to install some stuff for customizing Gnome3, but I wouldn't understand how that is connected to this problem.


    /etc/apt/sources.list
    Code:
     # deb cdrom:[Ubuntu 11.04 _Natty Narwhal_ - Release amd64 (20110427.1)]/ natty main restricted
    
    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://mirror.umd.edu/ubuntu/ precise main restricted
    deb-src http://mirror.umd.edu/ubuntu/ precise main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://mirror.umd.edu/ubuntu/ precise-updates main restricted
    deb-src http://mirror.umd.edu/ubuntu/ precise-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://mirror.umd.edu/ubuntu/ precise universe
    deb-src http://mirror.umd.edu/ubuntu/ precise universe
    deb http://mirror.umd.edu/ubuntu/ precise-updates universe
    deb-src http://mirror.umd.edu/ubuntu/ precise-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://mirror.umd.edu/ubuntu/ precise multiverse
    deb-src http://mirror.umd.edu/ubuntu/ precise multiverse
    deb http://mirror.umd.edu/ubuntu/ precise-updates multiverse
    deb-src http://mirror.umd.edu/ubuntu/ precise-updates multiverse
    
    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb http://us.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
    # deb-src http://us.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
    
    deb http://mirror.umd.edu/ubuntu/ precise-security main restricted
    deb-src http://mirror.umd.edu/ubuntu/ precise-security main restricted
    deb http://mirror.umd.edu/ubuntu/ precise-security universe
    deb-src http://mirror.umd.edu/ubuntu/ precise-security universe
    deb http://mirror.umd.edu/ubuntu/ precise-security multiverse
    deb-src http://mirror.umd.edu/ubuntu/ precise-security multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    deb http://archive.canonical.com/ubuntu precise partner
    # deb-src http://archive.canonical.com/ubuntu natty partner
    
    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    deb http://extras.ubuntu.com/ubuntu precise main
    deb-src http://extras.ubuntu.com/ubuntu precise main
    # deb http://ppa.launchpad.net/caffeine-developers/ppa/ubuntu precise main # disabled on upgrade to precise

  10. #10
    Join Date
    Sep 2012
    Location
    Virginia, USA
    Beans
    209
    Distro
    Ubuntu Development Release

    Re: Cannot Repair Package Catalog

    Thanks. I can see that you upgraded from Natty. Does this mean that upgraded from Natty directly to Precise?

    Also, do you have any idea why the system wants to install these development packages, like krb5-multidev, in the first place? Are you building applications that have to work with Kerberos? I see that you have -dev packages for CUPS, too -- are you developing/compiling applications that have to work with CUPS? It looks like there's a lot of oddness going on here.
    Last edited by jrog; September 24th, 2012 at 10:53 PM.
    Asus K55A (Core i5-3210M @ 2.5GHz/8GB RAM/120GB SSD/Intel HD 4000) with Ubuntu 12.10 Beta 2
    Compaq Presario C700 (Pentium Dual-Core @ 1.6GHz/2.5GB RAM/500GB HDD/Intel GM965) with Arch Linux and Linux Mint Debian Edition

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •