Results 1 to 10 of 10

Thread: Remove Logo / Watermark

  1. #1
    Join Date
    May 2012
    Beans
    357

    Remove Logo / Watermark

    Hello everybody,

    Is there a way to remove logo / watermark from a video using FFMPEG solution or any other program in a command line.

    Thank you in advance

  2. #2
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Remove Logo / Watermark

    There are videofilters in ffmpeg & mplayer (delogo)

    grossly simplied cmd line:
    ffmpeg -i inputfile -vf "delogo" out.mpg

    Can set the active "delogo" region of the video frame.
    http://ffmpeg.org/ffmpeg.html#delogo

    Might have to build your ffmpeg or use Jon Severrisson ppa to get video-filters.
    Think the mplayer delogo feature has been around for sometime..
    Last edited by BicyclerBoy; September 20th, 2012 at 05:16 AM.

  3. #3
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Remove Logo / Watermark

    Does the logo/watermark indicate copyright information, etc?
    The Left Coast Geek * The Community ATI Driver Wiki * Find what you need in the Ubuntu Community wikis

    Don't let the truth get in the way of a good story!
    This universe is crazy. I'm going back to my own.


  4. #4
    Join Date
    May 2012
    Beans
    357

    Re: Remove Logo / Watermark

    @BicyclerBoy: Oh, thanks

    Code:
    ffmpeg -i 4wX5bMF_a_s.mp4 -vf "delogo=x=10:y=100" out.mp4
    
    [delogo @ 0x806ae20] Option w was not set.
    Error initializing filter 'delogo' with args 'x=10:y=100'
    Error opening filters!
    @QIII: it is a website written there

  5. #5
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Remove Logo / Watermark

    Post the ffmpeg version..

    Like I said before ? you need a recent ffmpeg build..
    ffmpeg has been replaced (in Ubuntu) by libav project "avconv"

    Your cmd is complaining that w is not set..so set w...

    I'm using this
    ffmpeg version 0.10.4-6:0.10.4-0ubuntu0jon2
    & this cmd is valid syntax:
    ffmpeg -f v4l2 -i /dev/video0 -vf "delogo=x=0:y=0:w=100:h=77:band=10" out.mpg

  6. #6
    Join Date
    May 2012
    Beans
    357

    Re: Remove Logo / Watermark

    Code:
    Version: 6:0.10.4-0ubuntu0jon2~lucid2
    this is the output result:

    Code:
    [video4linux2,v4l2 @ 0x806f020] ioctl(VIDIOC_QUERYCAP): Inappropriate ioctl for device
    4wX5bMF_a_s.mp4: Inappropriate ioctl for device

  7. #7
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Remove Logo / Watermark

    My cmd line was just syntactically correct not a useful cmd for you..

    My cmd captures my netbook webcam & delogos it..just rework your command..

    Your cmd is complaining that w is not set..so set w...

  8. #8
    Join Date
    May 2012
    Beans
    357

    Re: Remove Logo / Watermark

    something like:

    Code:
    $ ffmpeg -i trimmed.mp4 -strict experimental -vf "delogo=x=20:y=350:w=100:h=100:band=100:show=1" outTrimmed.mp4
    Can we make any background color?

  9. #9
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Remove Logo / Watermark

    The :show=1 colour could be fixed..maybe the band value can change it..
    The green colour block is to help you set the x:y:w:h values..

    :show=0 (the default value) replaces logo with pixels interpolated from surroundings..
    :band might work better with values like 2 to 20 & not =100..

  10. #10
    Join Date
    May 2012
    Beans
    357

    Re: Remove Logo / Watermark

    ThxBicyclerBoy

    I'll play around these options and get back to you

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •