Hi there

I recently installed ubuntu using wubi. Everything was going fine until I edited my /etc/default/grub file by adding radeon.audio=1 to the GRUB_CMDLINE_LINUX variable because my HDMI sound wasn't working.
When I unplugged the HDMI cable the screen went black and stayed like that. I then restarted my laptop and attempted to boot into ubuntu without success.
Resarting and trying a few times ended with different screens, one was blank, and sometimes I would get into the grub prompt.
I couldn't boot from the grub prompt following these instructions either http://ubuntuforums.org/showpost.php...7&postcount=33

I have tried four fixes to date in the following order
1. Replace the wubildr with a new file, didn't help my problems

2. I have tried solution #2 from: http://ubuntuforums.org/showthread.php?t=1639198

Code:
sudo mkdir /media/win 
sudo mount /dev/sda1 /media/win
sudo mount -o loop /media/win/ubuntu/disks/root.disk /mnt
sudo cp -p /media/win/wubildr /media/win/wubildr.save
sudo cp -p /media/win/ubuntu/winboot/wubildr /media/wi
3. I have tried solution #1 from the same link which causes the following on booting into ubuntu "Failre to load_video" "Could not load /lib/modules/3.2.0-24-generic/modules.dep"

Code:
sudo mkdir /media/win 
sudo mount /dev/sda1 /media/win
sudo mount -o loop /media/win/ubuntu/disks/root.disk /mnt
sudo cp /mnt/boot/grub/grub.cfg /mnt/boot/grub/grub.cfg.copy
sudo chmod +w /mnt/boot/grub/grub.cfg
gksu gedit /mnt/boot/grub/grub.cfg
Remove all lines in the file from the start of the file up to, but not including, the following menuentry
Code:
### BEGIN /etc/grub.d/10_lupin ###
4. I have used boot repair the output of which is here:
http://paste.ubuntu.com/1212958

I am at a loss as I have never used Linux before.
I don't have any important info on my ubuntu is it best to re-install and try a partitioned install? But then how do I get around the problem of Radeon not being recognized?

Thank you for your help