Results 1 to 3 of 3

Thread: Installing Ubuntu on a MBP 8 1

  1. #1
    Join Date
    Mar 2013
    Beans
    8

    Installing Ubuntu on Macbook Pro 8 1

    Hey guys so I am running into some problems installing ubuntu on my macbook pro so let me run down the following information for you:

    Macbook Pro 8 1 with rEFInd installed
    At one point I had ubuntu installed on the MBP along side Mountain Lion and it was working great. I started to look into Android Development, specifically AOSP, and saw I need way more space. So I decided to get a drive caddy and replace my ODD that I never use, I threw in an "older" intel SSD, SATA II as I heard SATAIII drives have problems in the ODD spot, but thats fine with me.

    I did a fresh install of ML on the primary drive and ensured the newly added second drive would show up in ML, which it did. At this point I moved on to installing Ubuntu 12.10. I grabbed the MAC version of the ISO, verified the disc.

    I did not have access to a USB ODD at the time so I created a USB Disk via the automated method ubuntu suggested and even the manual way on OSX; rEFInd has no problem seeing the USB stick, it showed up as Windows, just like it did before selected that and when it tried to boot I get Missing Operating System. No biggie I thought, so I tried holding down ALT, selecting the USB and recieved the same error message. I thought this was stranged but thought maybe I will just need to use an ODD to install.

    So I found a USB ODD drive, hooked it up and burned a fresh new copy of ubuntu 12.10+MAC. It was again recognized by rEFInd as Windows and when I try to boot off the USB ODD i get the following message that just sits there "loading bootlogo... and a blinking cursor." I then tried just holding down ALT and booting from the disc only to get the same situation.

    What am I overlooking or doing incorrectly? I have tried searching and searching but couldn't really find an answer to my problem, a few different things to try but none have worked, I have a feeling some how its related to using an a SSD in the ODD bay but I dont see how that could cause a problem like this.

    Thanks.

  2. #2
    Join Date
    Mar 2013
    Beans
    8

    Installing Ubuntu on a MBP 8 1

    Hey guys so I am running into some problems installing ubuntu on my macbook pro so let me run down the following information for you:

    Macbook Pro 8 1 with rEFInd installed
    At one point I had ubuntu installed on the MBP along side Mountain Lion and it was working great. I started to look into Android Development, specifically AOSP, and saw I need way more space. So I decided to get a drive caddy and replace my ODD that I never use, I threw in an "older" intel SSD, SATA II as I heard SATAIII drives have problems in the ODD spot, but thats fine with me.

    I did a fresh install of ML on the primary drive and ensured the newly added second drive would show up in ML, which it did. At this point I moved on to installing Ubuntu 12.10. I grabbed the MAC version of the ISO, verified the disc.

    I did not have access to a USB ODD at the time so I created a USB Disk via the automated method ubuntu suggested and even the manual way on OSX; rEFInd has no problem seeing the USB stick, it showed up as Windows, just like it did before selected that and when it tried to boot I get Missing Operating System. No biggie I thought, so I tried holding down ALT, selecting the USB and recieved the same error message. I thought this was stranged but thought maybe I will just need to use an ODD to install.

    So I found a USB ODD drive, hooked it up and burned a fresh new copy of ubuntu 12.10+MAC. It was again recognized by rEFInd as Windows and when I try to boot off the USB ODD i get the following message that just sits there "loading bootlogo... and a blinking cursor." I then tried just holding down ALT and booting from the disc only to get the same situation.

    What am I overlooking or doing incorrectly? I have tried searching and searching but couldn't really find an answer to my problem, a few different things to try but none have worked, I have a feeling some how its related to using an a SSD in the ODD bay but I dont see how that could cause a problem like this.

    Thanks.

  3. #3
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    11,882
    Distro
    Lubuntu 16.04 Xenial Xerus

    Re: Installing Ubuntu on a MBP 8 1

    Please don't double-post.
    Merged.
    Bringing old hardware back to life. About problems due to upgrading.
    Please visit Quick Links -> Unanswered Posts
    Don't use this space for a list of your hardware. It only creates false hits in the search engines.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •