Results 1 to 5 of 5

Thread: Grub on corporate Laptop, wont boot windows

  1. #1
    Join Date
    May 2012

    Red face Grub on corporate Laptop, wont boot windows

    Hey all... I'm a pretty seasoned Linux user for the most part, but this one has be a pretty stumped, and my experience with grub/burg is dealing mostly with the normal "I installed Windows and now can't get into Linux" and vice-versa.

    I installed Ubuntu 12.04 last night on my corporate laptop, done this before and everything worked ok, however just got a new laptop and suspect the HD is encrypted or something along those lines.

    Grub correctly picked up the Windows Partition, which is labeled "System Reserved", however this partition is much smaller than my Windows partition ( See command output below ). Also in the commands below and in GParted the drive I suspected Windows to boot for isn't seen in some instances, and GParted thinks it may be defective somehow. I'm almost sure this isn't the case since this all happened immediately after my install of Ubuntu, before everything was running fine in Windows.

    Any solutions to try here? How can I know it's encrypted, corrupt or something else? Really hoping it's not encryption, only dang reason I need Windows is for VPN( Linux isn't supported at all I tried lol )

    fdisk -l showing /dev/sda2(What I suspected should be my main Win OS Partition) as being shown

    # /boot/burg$ sudo fdisk -l
    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disk identifier: 0x85bf8bca
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *        2048     1808383      903168    7  HPFS/NTFS/exFAT
    /dev/sda2         1808384   399860399   199026008    7  HPFS/NTFS/exFAT
    /dev/sda3       399861760   625139711   112638976   83  Linux
    blkid output NOT showing /dev/sda2

    # /boot/burg$ sudo blkid
    /dev/sda1: LABEL="System Reserved" UUID="26A48C0BA48BDBA5" TYPE="ntfs" 
    /dev/sda3: UUID="22ff2930-9eb9-4951-b4ae-1826969c8732" TYPE="ext4"
    burg.cfg excerpt for Windows entry

    ### BEGIN /etc/burg.d/30_os-prober ###
    menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
            insmod ntfs
            set root='(hd0,1)'
            search --no-floppy --fs-uuid --set 26a48c0ba48bdba5
            chainloader +1
    ### END /etc/burg.d/30_os-prober ###
    GParted Screenies:

  2. #2
    Join Date
    May 2012

    Re: Grub on corporate Laptop, wont boot windows

    Ahhh... Forgot the error when I choose the Windows boot option, get the windows(Dos?) black screen with text indicating that an expected resource is unavailable. Also I had to install linux by shrinking the Win partition in Windows, as GParted obviously has problems with that partition and didn't have options to shrink it during setup of Ubuntu( During install I mean )

  3. #3
    Join Date
    Jun 2009
    SW Forida
    Ubuntu 16.04 Xenial Xerus

    Re: Grub on corporate Laptop, wont boot windows

    Always best to shrink the Windows partition with Windows tools. Windows always wants to run chkdsk after a resize, so you need to reboot several times after the resize.

    If it has not run chkdsk you need to do that.

    The 100MB boot/repair partition is how Windows 7 installs. That gives the option to encrypt the main install and you should be able to get to the Windows recovery or repair in that partition. Some have posted that it is difficult as you just about have to hit the f8 (is it f8?, have not used Windows for ages) almost at the same time as you press enter in grub on the Windows boot entry. Some said try several times.

    Always best to have a repairCD or liveCD for the current version of every system installed.

    The vendor recovery DVDs are just an image of your drive as purchased. If you have housecleaned a lot of cruft normally included, run many updates with many reboots, and added software you may want a full back up.
    Backup windows before install - post by Mark Phelps
    Another suggestion by srs5694

    Make your own Windows repairCD (not vendor recovery):

    Windows 7 repair USB, Also Vista if service pack installed
    For more info on UEFI boot install & repair - Regularly Updated :
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  4. #4
    Join Date
    May 2007
    Virginia, USA
    Ubuntu Mate Development Release

    Re: Grub on corporate Laptop, wont boot windows

    Windows WAS on sda2; only the Win7 boot loader was on sda1. With what is seen in the gparted screenshot, looks like you may have wiped out Win7.

    GRUB will still think it's there because it sees the boot loader files in sda1.

    Since there appears to be no Recovery partition, if you have no Win7 backup, you would have to reinstall it to get it back.
    Ubuntu 17.04 Mate, Mint 18.1 Mate; MS Win 8.1, MS Win10 Pro.
    Will not respond to PM requests for support -- use the forums.

  5. #5
    Join Date
    Jan 2008
    Ubuntu Development Release

    Arrow Re: Grub on corporate Laptop, wont boot windows

    Quote Originally Posted by Mark Phelps View Post
    Windows WAS on sda2
    But before reinstalling Windows, he can try fixing the partition, or recovering documents via TestDisk.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts