Results 1 to 2 of 2

Thread: 12.04 Problem With Addon USB WLAN Adaptor Vanished

  1. #1
    Join Date
    Jun 2012

    Question 12.04 Problem With Addon USB WLAN Adaptor Vanished

    I'm using a Addon NWU271 Wireless USB Adaptor on Ubuntu 12.04.

    When I initially plugged it in the device was automatically recognised by Ubuntu and the wireless symbol was shown and it detected my wireless network SSID. However for some reason I couldn't get it to authenticate.

    Therefore I tried to use the ndiswrapper solution and the Windows driver. However with this installed the device was no longer recognised. So I uninstalled it.

    However now I can't get the wireless network to start at all.

    From a lssub I get this:

    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 005: ID 0bda:8176 Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN

    So the device is seen but wireless network won't start.

    iwconfig shows no wireless:

    lo no wireless extensions.

    eth0 no wireless extensions.

  2. #2
    Join Date
    Jan 2011
    Ubuntu 12.04 Precise Pangolin

    Smile Re: 12.04 Problem With Addon USB WLAN Adaptor Vanished RealTek RTL8188-8192 (Fixed)

    This thread comes up high in the search rank so here's an update to this problem, which has a solution.

    The open source driver is the trouble. Apparently that's being addressed in development, but no fix as of this posting. However, by installing RealTek's proprietary drivers, these adapters can be made to work normally. After the upgrade, mine not only had unbroken connection, but a stronger signal and faster data transfer as well.

    First, if accessing the Internet through the adapter and the connection fails before the driver can be downloaded, try unplugging from one USB port and inserting in another. Using a USB hub has a similar effect.

    The top three posts are atconley's, chamber's and the bug report. The following is a combination of the best features from each, which worked for me:

    1. With the adapter connected (not convulsing), at a terminal, type lsusb and note the version number on the RealTek line (Ex. In 'Realtek Semiconductor Corp. RTL8188CUS 802.11n WLAN', it would be "RTL8188CUS").
    2. From RealTek's Drivers & Utilities page, select and download the most recent driver package for your version (Linux, of course).
    3. Unzip the file. Easiest way is click to open in File Roller (archive manager) and click Extract. Close File Roller.
    4. In unzipped folder, open 'driver' subfolder and extract the only file (Ex. rtl8188C_8192C_usb_linux_v3.4.4_4749.20120730.tar. gz), again easiest by clicking to open in FRoller and hitting Extract.
    5. Back in Nautilus (file browser), click just-unzipped folder to open it, then do a ctrl-L and ctrl-c.
    6. In terminal, change to that directory by typing "cd " and ctrl-shft-v (Ex. cd /home/yourname/Downloads/RTL8188C_8192C_USB_linux_v3.4.4_4749.20120806/driver/rtl8188C_8192C_usb_linux_v3.4.4_4749.20120730).
    7. One at a time, enter the following commands:
      sudo make install
      sudo make clean
      sudo gedit /etc/modules
    8. In the gedit window that opened, append the following line, save and exit:
    9. Back in terminal, paste:
      sudo gedit /etc/modprobe.d/blacklist.conf
    10. Append the following, save and exit:

      # Buggy driver for RealTek Wireless-N adapter
      blacklist rtl8192cu
    11. Reboot to activate the fix.

    And a few last notes:

    1. Tidy up by deleting the downloaded zip file, but see notes 2. and 3. below.
    2. Kernel updates will break this fix. On restart after such an update, it will be obvious when no wireless service is available. For this reason, it is best to leave the proprietary driver folders in place. Then whenever a kernel update breaks the wireless, pick up at step 5. and do everything through sudo make clean.
    3. When a future update solves this problem, then the proprietary driver folders can be deleted.
    4. Hopefully this bug will be fixed with the next release. Or the next...

    Thanks to those who posted earlier solutions.
    Last edited by u2nTu; September 22nd, 2012 at 05:57 PM. Reason: Add note on kernel updates


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts