Results 1 to 3 of 3

Thread: 12.04 boots only when I pick previous version->recovery->resume

  1. #1
    Join Date
    Sep 2008
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    12.04 boots only when I pick previous version->recovery->resume

    I have upgraded from 11.04 to 12.04 (through an 11.10 that didn't boot either) using 12.04 Live CD. The install had an issue with creating a user, so I had to LiveCD-boot and chroot to create a user to see my files again.

    Now what happens is: it can never boot normally (says does not see the HDD at /dev/sda). The HDD is actually an Adaptec RAID array which does become /dev/sda if using recovery mode. In Grub I have to always use Previous Linux Versions -> kernel # (recovery mode) and then hit resume normal boot when recovery mode menu appears. Then it boots fine.

    right now
    uname -a shows 3.0.0-25-generic kernel (is this a 12.04 kernel, BTW?)

    Does anyone have a clue as to where to start fixing this?

    Thanks!
    ***********************************
    To Build And Overclock!

  2. #2
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 16.04 Xenial Xerus

    Re: 12.04 boots only when I pick previous version->recovery->resume

    That is an old kernel, so it looks like updates did not complete.

    Can you run this, or use liveCD and run this;

    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
    https://help.ubuntu.com/community/Boot-Repair
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration an diagnose advanced problems.

    It also helps you chroot into your system so you can do updates, if you cannot boot.

    Manually chroot:
    To chroot, you need the same 32bit or 64 bit kernel. Best to use same version.
    https://help.ubuntu.com/community/BasicChroot
    drs305 chroot to purge & reinstall grub2
    http://ubuntuforums.org/showthread.php?t=1581099
    #Then run whatever other commands needed - no sudo needed if chroot (maybe good to run "df- H" and "cat /etc/issue" to be certain #you mounted the correct partition).
    #Commands once in chroot:
    #if not chroot use: sudo -i
    #houseclean
    apt-get autoclean # only removes files that cannot be downloaded anymore (obsolete)
    apt-get clean
    #refresh
    apt-get update #resync package index
    apt-get upgrade #newest versions of all packages, update must be run first
    #would upgrade you to the latest kernel in the repositories
    #dist-upgrade is also able to remove existing packages if required
    apt-get dist-upgrade
    apt-get -f install
    dpkg --configure -a
    # reinstall desktop
    apt-get remove ubuntu-desktop
    apt-get install ubuntu-desktop
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  3. #3
    Join Date
    Sep 2008
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    Lightbulb Kernel update solved it

    oldfred, you were right, the old kernel is what was giving me these problems and another one I did not mention: it would never mount USB drives and was generally unstable.

    I ended up just running
    Code:
    sudo apt-get update && sudo apt-get upgrade
    at some point after adding multiverse (if memory serves) repository and an option to upgrade kernel has come up, I did it and now I'm in much better shape, pretty much all the post-upgrade issues are gone.

    My kernel is now 3.2.0-30-generic

    I did do the boot repair but I did it before upgrading kernel and it did not fix the issue but the kernel update did.

    Thanks!
    ***********************************
    To Build And Overclock!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •