I will start by saying that Ubuntu 12.04 is installed on my laptop alongside Windows 7. I have tried plugging my laptop directly into my router and modem, but it will not connect on Ubuntu. It connects just fine on Windows 7. I have even tried reverting to Ubuntu 11, but the problem persisted.

Since I cannot copy and paste the results from commands as shown directly on my laptop, I will do my best to type them up char for char.

In case it matters, I'd also like to state that I am new to Linux in general.

lspci results in:

Network controller:  Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)

no wireless extensions.

wlan0 IEEE 802.11bgn ESSID off/any
Mode:Managed Acces Point: Not-associated Tx=Power=20 dBm
Retry long limit: 7  RTS thr=2347 B  Fragment thr:off
Power Management:off
So, I cannot connect to a wireless or wired network at all from Ubtuntu on my laptop, but I can on Windows 7. However, Ubuntu DOES recognize my network, and nearby networks.

My PC is currently connected to a router via a Netgear USB wireless adapter. Every time I attempt to connect to my wireless on Ubuntu, my PC loses its connection. I have tested this multiple times, and the connections always drops when I attempt to connect on Ubuntu.