Results 1 to 5 of 5

Thread: Update packages that won't install problem

  1. #1
    Join Date
    Aug 2012
    Beans
    13

    Update packages that won't install problem

    Hi,
    Update manager has 6 recommended updates available, but when I try install them I receive an this report:

    requires installation of untrusted packages: the action would require the installation of packages from not authenticated sources.
    Details:
    build-essential glib-networking glib-networking-common glib-networking-services linux-firmware policykit-1-gnome

    The updates are:

    Recommended updates:
    1.Information list of build-essential packages
    Changes for the versions:
    Installed version: 11.5ubuntu2
    Available version: 11.5ubuntu2.1

    Version 11.5ubuntu2.1:

    * Revert the previous change, we shouldn't be foreign (LP: #1034568)
    If you do not plan to build Debian packages, you don't need this package.
    Starting with dpkg (>= 1.14.18) this package is required for building Debian packages.
    This package contains an informational list of packages which are considered essential for building Debian packages.
    This package also depends on the packages on that list, to make it easy to have the build-essential packages installed.
    If you have this package installed, you only need to install whatever a package specifies as its build-time dependencies to build the package.
    Conversely, if you are determining what your package needs to build-depend on, you can always leave out the packages this package depends on.
    This package is NOT the definition of what packages are build-essential; the real definition is in the Debian Policy Manual. This package contains merely an informational list, which is all most people need.
    However, if this package and the manual disagree, the manual is correct.

    2. network-related giomodules for GLib
    Changes for the versions:
    Installed version: 2.32.1-1ubuntu1
    Available version: 2.32.1-1ubuntu2

    Version 2.32.1-1ubuntu2:

    * debian/patches/gnutls-Try-to-find-root-certificates-locally-if-no.patch:
    - If a server erroneously sends us a root certificate, and it
    is not anchored, then try to lookup a certificate for the same
    issuer in the database (LP: #1033516)
    Thanks to Stef Walter

    3. network-related giomodules for GLib - data files
    4. network-related giomodules for GLib - D-Bus services
    5. Firmaware for Linux kernel drivers
    6. GNOME authentication agent for policyKit-1

    I have tried one at a time and none will instal.
    Questions:
    1. Are they necessary?
    2. If not how do I stop them from coming up?
    3. If they are, what do I do to get them to instal?
    4. I recently installed a hp printer and sometimes i receive a message saying 'updates are available for hp printer, but when I click to instal them nothing happens - are these updates perhaps for that?

    Regards,
    gonda
    Last edited by Gonda; September 9th, 2012 at 03:25 PM.

  2. #2
    Join Date
    Nov 2008
    Beans
    Hidden!

    Re: Update packages that won't install problem


  3. #3
    Join Date
    Aug 2012
    Beans
    13

    Re: Update packages that won't install problem

    thanks, will go and take a look

  4. #4
    Join Date
    Aug 2012
    Beans
    13

    Re: Update packages that won't install problem

    Thanks for that link jerrrys,

    I followed these instructions and the updates downloaded perfectly.
    1. open a terminal
    2. sudo apt-get update
    3. sudo apt-get upgrade

  5. #5
    Join Date
    Nov 2008
    Beans
    Hidden!

    Re: Update packages that won't install problem


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •