Page 103 of 206 FirstFirst ... 35393101102103104105113153203 ... LastLast
Results 1,021 to 1,030 of 2053

Thread: Comprehensive Sound Problem Solutions Guide

  1. #1021
    Join Date
    Jun 2008

    Sound not working

    Hello, I am extremely new to linux.
    i have installed hardy heron (8.04 lts)
    on my lenovo n200 notebook.

    specs are: 1.66 GHz, Intel Core 2 Duo T5450, L2 Cache Size 2 MB, fsb 667 MHz
    i am single booting to ubuntu.
    I have ALC861VD audio chipset.

    aplay -l gives
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: ALC861VD Analog [ALC861VD Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0


    lspci -v gives

    00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
    Subsystem: Lenovo Unknown device 384e
    Flags: bus master, fast devsel, latency 0, IRQ 22
    Memory at fc300000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>

    (for audio)

    I dont find drivers for ICH8 here:

    Please help me!

  2. #1022
    Join Date
    Jun 2008

    Re: Comprehensive Sound Problem Solutions Guide

    I get to step two in the guide and find this

    04:09.0 Multimedia audio controller: Creative Labs SB X-Fi
    Subsystem: Creative Labs X-Fi Platinum
    Flags: bus master, medium devsel, latency 64, IRQ 5
    I/O ports at c880 [size=32]
    Memory at fe800000 (64-bit, non-prefetchable) [size=2M]
    Memory at f8000000 (64-bit, non-prefetchable) [size=64M]
    Capabilities: <access denied>

    At step three i go to the alsa site and after much confused searching it says that x-fi is not supported.

    However I downloaded a linux driver for my card from the creative site
    but I don't know HOW to make it work... because I have only ever used windows until last week and so a lot of what I read on this forum is unintelligible jargon...

    If someone could offer some advice, in very simple newbie terms, I'd be very grateful.

  3. #1023
    Join Date
    Oct 2005
    Xubuntu 8.04 Hardy Heron

    Question Re: Comprehensive Sound Problem Solutions Guide

    Hopefull someone here is able to help me:

    I posted a thread on my own for this problem, but there are no replies!

    I've had sound working in Gutsy by simple adding this line to /etc/modprobe.d/alsa-base:
    options snd-hda-intel model=auto
    After upgrading to Hardy all sound is gone. I've tried adding every option given for my type of card in the thread that originally gave me my sound to no availability.

    Then with dmesg I found the following error:
    [ 8637.837903] hda-intel: Invalid position buffer, using LPIB read method instead.
    Which I was able to fix by adding position_fix=1 and index=0 to the /etc/modprobe.d/alsa-base file.

    As I can't seem to find any other errors with my sound setup I'm wondering which actions to take now to found any possible errors!

    Thanks in advance,

    Arjan Gelderblom.

    P.s. Here is some output from commands that are of interest

    $ cat /proc/asound/card0/codec#* | grep Codec
    Codec: Realtek ALC660-VD
    Codec: Generic 1543 Si3054
    $ lshw
                    description: Audio device
                    product: Radeon X1200 Series Audio Controller
                    vendor: ATI Technologies Inc
                    physical id: 5.2
                    bus info: pci@0000:01:05.2
                    version: 00
                    width: 64 bits
                    clock: 33MHz
                    capabilities: bus_master cap_list
                    configuration: driver=HDA Intel latency=64 module=snd_hda_intel
    $ aplay -l
    card 0: SB [HDA ATI SB], device 0: ALC861VD Analog [ALC861VD Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 6: Si3054 Modem [Si3054 Modem]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    $ cat /proc/asound/cards
     0 [SB             ]: HDA-Intel - HDA ATI SB
                          HDA ATI SB at 0xfebf4000 irq 18
     1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                          HDA ATI HDMI at 0xfd7ec000 irq 20
    $ cat /etc/modprobe.d/alsa-base
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7
    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; : ; }
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm && { /sbin/modprobe --quiet snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer && { /sbin/modprobe --quiet snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq && { /sbin/modprobe --quiet snd-seq-midi ; /sbin/modprobe --quiet snd-seq-oss ; : ; }
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe -Qb snd-seq ; }
    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe -Qb saa7134-alsa ; : ; }
    # Load snd-seq for devices that don't have hardware midi;
    #   Ubuntu #26283, #43682, #56005; works around Ubuntu #34831 for
    #   non-Creative Labs PCI hardware
    install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe -Qb snd-seq ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-usx2y index=-2
    options snd-usb-caiaq index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    options snd-hda-intel enable=1 index=0 model=auto position_fix=1

  4. #1024
    Join Date
    Jun 2007

    Re: Comprehensive Sound Problem Solutions Guide

    Quote Originally Posted by megamoo View Post
    At step three i go to the alsa site and after much confused searching it says that x-fi is not supported.
    Most X-Fi models are supported under OSS4. Follow the link in my sig.
    What would happen if your hard disk died right now?

  5. #1025
    Join Date
    Jun 2008

    Re: Comprehensive Sound Problem Solutions Guide

    Thanks for the quick reply
    I'm going through the `Installing OSS 4.0 From a .deb package` and it looks as though Im getting somewhere but
    at step 6 I get
    megamoo@megamoo-desktop:~$ sudo dpkg -i oss-linux_v4.0-1016_i386.deb
    dpkg: error processing oss-linux_v4.0-1016_i386.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    I get the same thing when I try to double click on it, It says there is no such file?? Is this a new to Linux thing??

  6. #1026
    Join Date
    Jun 2008

    Re: Comprehensive Sound Problem Solutions Guide

    Hi everyone.

    I really want to try out Ubuntu and just installed 8.4 as a dual boot setup with XP this weekend. Everything seems to be working fine...except, of course, for sound. I get no sounds from my external speakers at all. I've tried everything that I've read throughout these forums, and no go.

    Temujin: I've looked through your post for configuring alsa-base, but I'm confused about something. Sorry if it's a stupid question, but it's late and I've been staring at this monitor all day. My brain's a little mushy right now (heh). My question that list of model names...what exactly am I looking for? Model name for what? I don't see anything in that list that matches anything to do with my system. Looks like it's mostly all laptops. Again, sorry, but I'm extremely new to this whole Linux thing. I want to learn it, though, and be rid of the monkey on my back that is Windows. I gotta get out before I'm forced to start using Vista!

    I'm trying to do all this with an Asrock P4V88 with onboard sound...VIA VT8237. I'm using Logitech 2.1 speakers...couldn't tell ya a model # or anything for those. They're hand-me-down's.

    Everything works dandy in Windows, so I know the speakers aren't blown or anything...and I know everything's hooked up correctly.

    I've just been working on this all weekend and I'm spent. I'm ready to give up on Ubuntu, but I really don't want to. Can ya give me anything?

    Preferably in the simplest terms possible?

    Much appreciation for everyone involved in this. It looks like getting sound has been a harrowing experience for a lot of people. Hopefully I can be the next success story.

  7. #1027
    Join Date
    Jun 2008

    Re: Comprehensive Sound Problem Solutions Guide

    Hi. I'm newbie to linux.since i first installed to my laptop, I've had problem with the sound. I've tried everything but nothing seems to work. Alsa installation went smoothly but no sound still. I also tried the OSS version but doesn't seem to work too. no error messages but NO SOUND. I found a file in driverguide but made for redhat. I wonder if it could be used in ubuntu?
    Attached Files Attached Files

  8. #1028
    Join Date
    Jun 2008

    Re: Comprehensive Sound Problem Solutions Guide

    Well, I don't know what I did, but sound is fine now. I made so many changes according to different threads in this forum, that I got confused about what I added and deleted, so I wound up just reformatting and installing ubuntu all over again from scratch. All of the sudden....sound works!

    Now if I can just figure out how to control the volume from my keyboard, lol.

  9. #1029
    Join Date
    Jun 2008

    Re: Comprehensive Sound Problem Solutions Guide

    Ok I managed to solve my problem by using a "-" and not a "_" in the name of the file
    After that Temüjin's guide on installing oss worked great =D>

  10. #1030
    Join Date
    Jul 2008

    Re: Comprehensive Sound Problem Solutions Guide

    I've installed Ubuntu 8.04 today (first time Linux user) and I'm not getting any sound. The guide was very helpful, I followed all the steps, and everything worked except that I still don't have any sound.
    My card is listed, and I believe I managed to install the driver?
    My card is Creative Labs SB Audigy LS, and I did the snd-ca0106 which is the driver specified.
    Any help would be much appreciated. I'm not sure what other info you need, but I'd be happy to supply it if I can. I'm very new with the terminal and commands, so I find explanations of the commands useful. Thanks

Page 103 of 206 FirstFirst ... 35393101102103104105113153203 ... LastLast


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts