It seems exo-open (which is used to launch the default applications) has problems with the return value of Google Chrome.

What works for me, thus, is to have the following shell script set as default "browser", which then redirects each launch request and all parameters to Google Chrome. Most important, it exits with return code 0 and exo-open is happy, no longer throwing the error.

/usr/bin/google-chrome $@
exit 0
Of course, make sure it's executable by setting chmod correctly, e.g., run "chmod u+x <scriptname>" after saving the script as <scriptname>.